Is there a way to get out of a frozen desktop?

I need to check this again, I may be mistaken about the above comment. It is possible that the focus was on a window rather than the desktop when I pressed alt-F2. On my last freeze I was unable to get krunner using alt-F2 but after clicking on the desktop background it worked. Don’t know if that matters, I will check further on this.

Additional info:

I usually close apps with the ‘X’ in the upper right of the window. With LibreOffice apps, using the ‘X’ I almost always cause a freeze of kwin. If I choose File-Close from the menu I have better success at not freezing. I don’t know if this info is useful in pinpointing my problem.

Yes, you do not need the Alt-SysRq actions for your current situation, and it also has nothing to do with solving the base problem.

But, for your information:

It is a binary setting. 184 means the bits are set as 010111000

Your setting of 184 means you have:

  • debugging dumps of processes etc. enabled (Alt-SysRq-t will dump a list of current tasks and their information to your console, and there are other dump keystrokes I will not bother listing at this time);
  • sync command enabled (Alt-SysRq-s);
  • remount read-only enabled (Alt-SysRq-u);
  • and reboot/poweroff is enabled (Alt-SysRq-b & Alt-SysRq-o).

You do not have the Alt-SysRq commands enabled that will allow you to:

  • take control of the keyboard (Alt-SysRq-r);
  • signal processes, such as issue term, kill, or oom-kill signals (so, Alt-SysRq-e & Alt-SysRq-i will not work, for example);
  • you cannot “nice” RT tasks and you cannot control the console logging level.

I’ve tried every suggestion, including the new fglrx. Nothing has worked, and as I mentioned in a prior post, I was unable to type input into the gdb “window” after a crash. I also tried a suggestion I saw posted several months ago regarding LibreOffice problems in Tumbleweed gnome, that suggestion was to delete libvclplug_gtk3lo.so. Rather than delete, I renamed libvclplug_kde4lo.so (so that I could restore it later if it didn’t help). It didn’t help and I will restore that file.

What really puzzles me is that LibreOffice did not crash until recently.

Short of reinstalling Leap, are there any other suggestions?

Well, yes, gdb stops kwin, so the display will not get refreshed any more.
I had hoped that setting KDE_DEBUG=1 would help, but apparently not.

So the only way is to debug it in text mode.
As a first step you could just run kwin_x11 in Konsole (without gdb), maybe the output would give a hint.

Although if it still happens with fglrx and only happens when closing LibreOffice, it’s probably not really a kwin problem…

I also tried a suggestion I saw posted several months ago regarding LibreOffice problems in Tumbleweed gnome, that suggestion was to delete libvclplug_gtk3lo.so. Rather than delete, I renamed libvclplug_kde4lo.so (so that I could restore it later if it didn’t help). It didn’t help and I will restore that file.

Ok, so you disabled the KDE integration.
But what about libvclplug_gtk3lo.so? This is known to cause problems.
Do you have that? If yes, try to rename/remove that as well.

And/or try to run LibreOffice like this to disable all desktop integration:

SAL_USE_VCLPLUGIN=gen libreoffice

Do you see the freezes then?

I don’t have that file.

And/or try to run LibreOffice like this to disable all desktop integration:

SAL_USE_VCLPLUGIN=gen libreoffice

Do you see the freezes then?

This works for me!! At least for a typical sequence that previously crashed. I’ll update some spreadsheets tonight and see if it continues to function properly.

Just to be clear, I am opening konsole in a normally running system.
I type in the above line and libreoffice opens and apparently all is running correctly. I close libreoffice and close konsole and all is well.

With this info are there any other steps I should take for diagnostics or just use libreoffice in this manner until an update shows up?

FYI, I finally found a bug report that indicates libreoffice 5.1.0 fixes what appears to be my problem.
https://bugs.documentfoundation.org/show_bug.cgi?id=94936

The version on my system & in YaST is 5.0.2.2

Thank you for all the help getting me to a workable solution.
jon

Great!
So it is indeed related to the desktop integration.

But as renaming libvclplug_kde4lo.so didn’t help, it cannot be a problem with the KDE integration.

Do you also have libreoffice-gnome installed? If yes, try to uninstall it as “fix”.
Or even better, uninstall ibus if you don’t need it, this forces the use of the gnome integration even in KDE.

As far as I can tell I do not have LO-gnome installed. Pkg’s LO-gnome extensions & gtk3 interface are not installed.

As for ibus, I don’t know what that is but I do have installed “libibus-1_0-5 - IBus libraries. This package contains the libraries for IBus”
Is this what you are suggesting I uninstall? I don’t know if I need it or not, according to wiki it is for multi-language? Seems like it is for logogram languages, is that correct? If so then as an English only speaker I guess I can safely remove it.

But then do I need to install the libreoffice gnome extensions to force the above mentioned gnome integration?

Hm, strange then if removing the KDE plugin doesn’t help, but the crash is gone with the generic plugin…

Just to be sure, the packages are called libreoffice-gnome and libreoffice-gtk3.

As for ibus, I don’t know what that is but I do have installed “libibus-1_0-5 - IBus libraries. This package contains the libraries for IBus”
Is this what you are suggesting I uninstall?

No, that is necessary.
You can uninstall “ibus” itself if it is installed.

I don’t know if I need it or not, according to wiki it is for multi-language? Seems like it is for logogram languages, is that correct?

No idea what “logogram languages” means exactly, but ibus is an input method engine, mainly intended for allowing users to enter asian text (but not exclusively).

See Input method - Wikipedia and Intelligent Input Bus - Wikipedia.

If you don’t know what it is, you likely don’t need it though… :wink:

But then do I need to install the libreoffice gnome extensions to force the above mentioned gnome integration?

Actually the point was to not use the gnome integration.
If ibus and libreoffice-gnome is installed, LibreOffice is forced to use the gnome integration. Apparently ibus works/worked better with the gnome integration and/or there are/were problems in combination with the KDE integration.

I suspected that the gnome integration might cause your crash though, as removing the KDE integration library didn’t help, and the crash seems to be gone with LibreOffice’s generic plugin.

None of above mentioned packages installed.

So I guess I’ll need to start LO from konsole with SAL_USE_VCLPLUGIN=gen libreoffice every time until I see something in an update.

Thanks for getting me this far.
Jon

You could also try to uninstall libreoffice-kde4, then the generic plugin should be used automatically.

Or edit the menu entry to run “SAL_USE_VCLPLUGIN=gen libreoffice”.
Or export SAL_USE_VCLPLUGIN=gen somewhere in an autostart file, e.g. create a script in /etc/profile.d/ that runs:

export SAL_USE_VCLPLUGIN=gen

or add that to /etc/bash.bashrc.local (create the file if it doesn’t exist) or ~/.profile or ~/.bashrc.