Is there a way to create a case insensitive (casefold) parttion on Tumbleweed?


Is it possible (in Tumbleweed) to create a partition that is case insensitive?

I checked with:

$ cat /sys/fs/ext4/features/casefold

if the kernel supports EXT4 casefolding but this seems not to be the case.

So now I am wondering whether there is a reliable way to create a partition with either F2FS, XFS or EXT4 on openSUSE that ignores case sensitivity and treats uppercase and lowercase UTF8 encoded file names as equal?

Can someone help here?

Also if this is not possible would creating an EXFAT or NTFS partition solve the issue without any big disadvantages (perfomance, reliability)?

Thanks for reading,

p.s.: Just for context:

I have to deal with one use case of a dual boot box with two users booting into windows and one user using openSUSE. They all share files on a public partition. Creating issues by sloppy naming…

The second case is a more casual one with wine games using community mods that mix upper and lower characters in file names creating issues after every update. For this there is the somewhat tedious workaround solution to mount squashfs files formated with FAT inside instead of using “real” folders. Still not ideal…

I do not know what you checked, but

bor@tw:~> cat /sys/fs/ext4/features/casefold
bor@tw:~> uname -r

Unless it suddenly changed in kernel 6.2.

Hmmm… that’s strange:

$ ~> uname -r 

$ ~> cat /sys/fs/ext4/features/casefold
cat: /sys/fs/ext4/features/casefold: file or directory not found 

$ -> sudo cat: /sys/fs/ext4/features/casefold 
cat: /sys/fs/ext4/features/casefold: file or directory not found 

Does Tumbeweed use a different default configuration for the kernel?

Or maybe you are right and kernel 6.2 is the problem…

Oooh !!

There is no EXT4 installed by default… who would have guessed…

Ok. So I’ll install that first I guess … :slight_smile:

You need to load ext4 module first.

Yes. I didn’t realize that I haven’t used any ext4 yet, so it obviously won’t load by default - stupid me! Sometimes missing the tree for the forest…




Works now as intended…