Is there a way how to properly update proprietary NVIDIA drivers?

Yesterday a new version of proprietary NVIDIA driver appeared among other updates on my OpenSuse 11.4. So I run the updates and then restarted X server in order to load new drivers. I got black screen and in log I found a common message about mismatch version between kernel module and drivers. It turned out that although the main packages (nvidia-computeG02, x11-video-nvidiaG02 ) were updated properly, I still had the old version of nvidia-gfxG02-kmp-desktop. So I manually updated this missing package, it really helped, X server started but all input devices stopped working (keyboard, touchpad, mouse) even though they worked in terminal. The xorg.log gave me warning that AllowEmptyInput is on and all input devices will be disabled. So I added a new line to Xorg.conf (“Option” “AllowEmptyInput” “Off”) and got finally everything working once again.

I included all the technical stuff because it might be helpful for someone but the question is how do I avoid this next time? As far as I remember, this is not the first time I had a problem with updating graphics drivers. In fact, I often excluded nvidia packages from updates in order to avoid extra stress and honestly I don’t remember the last time this kind of update went smoothly. So I guess I’m doing something wrong… I use standard OpenSuse 11.4, with default repositories (just Pacman, some KDE stuff and official nVidia repository for OpenSuse 11.4). The issue with not working keyboard and touchpad could be a hw specific problem but why the kmp package wasn’t automatically updated? It’s just weird…

The bug with the missing kmp is new and only affected a few users so far. It hit one of my systems too (among many others). I don’t know why.
Manually updating the kernel module package was the right thing to do: http://forums.opensuse.org/english/get-technical-help-here/hardware/474525-nvidia-driver-295-40-15-1-crashes-my-system-7.html#post2465440. But the problem might not happen anymore in future versions. Let us hope so!

Humm… I don’t think it is related with the missing module. AllowEmptyInput is an old hack but it is usually better if you can avoid it.

What’s weird is that it only hit three of us … or at least, you are the third person reporting this bug, while many might have updated the driver without problem in the meantime. Don’t kow. Anyway the solution you applied is the right one.

On 2012-05-31 15:16, tobice wrote:
> I use standard OpenSuse 11.4, with default repositories (just
> Pacman, some KDE stuff and official nVidia repository for OpenSuse
> 11.4). The issue with not working keyboard and touchpad could be a hw
> specific problem but why the kmp package wasn’t automatically updated?
> It’s just weird…

Well, updates have problems often. Solution? I do not update, I only do
security updates.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Humm… I don’t think it is related with the missing module. AllowEmptyInput is an old hack but it is usually better if you can avoid it.

It probably isn’t. While I was trying to fix this I switched for a moment to “nv” driver and input devices didn’t work as well, however at that point I just thought that it would disappear once the nvidia driver is back again. But definitely this was caused by the update, although I don’t remember which packages have been updated.

Another problem is that my KDE feels slower with new driver version and eats to much cpu. I’ll try to downgrade, if it is possible.

On 2012-05-31 17:16, tobice wrote:
> But definitely this was caused by the update, although I
> don’t remember which packages have been updated.


rpm -q -a --queryformat "%{INSTALLTIME};%{INSTALLTIME:day}; \
%{BUILDTIME:day}; %{NAME};%{VERSION}-%-7{RELEASE};%{arch}; \
%{VENDOR};%{PACKAGER};%{DISTRIBUTION};%{DISTTAG}
" \
| sort | cut --fields="2-" --delimiter=\; \
| tee rpmlist.csv | less -S

or

rpm -q -a --queryformat "%{INSTALLTIME}	%{INSTALLTIME:day} \
%{BUILDTIME:day} %-30{NAME}	%15{VERSION}-%-7{RELEASE}	%{arch} \
%25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}
" \
| sort | cut --fields="2-" > rpmlist


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thank you, but I’ve decided not to dig into it, unfortunately I have no time for that and besides, everything is finally working as it should. The system seemed slow but I managed to identify the problem and fix it. Since it was quite weird and I couldn’t find any solution online, I’ll post it here…

The problem was with typing. Typing fast on the keyboard caused huge cpu usage by X server and after like 100 characters the system became unresponsive. I could continue writing but I couldn’t for example use Alt-Tab to switch to another window. I had to wait for a while. Generally the system reacted slowly when evaluating keyboard shortcuts, that’s why for example switching desktops seemed so slow. Funny was, that it only affected KDE, when I tried E16, it seemed ok. However I wasn’t able to find anything about this problem (maybe I just used wrong keywords?), so I tried several things and what finally helped was changing the keyboard driver from kbd to evdev in Xorg.conf. The original xorg.conf was generated by nvidia-xconfig and as a keyboard driver there was kbd. Firstly I tried to remove the whole keyboard section, it didn’t help, so I changed kbd to evdev and problem was solved, but honestly, I have no idea why :slight_smile:

kbd is wide deprecated. So are InputDevice sections in xorg.conf. evdev handles both mouse and keyboard. To use kbd, you have to turn off AutoAddDevices and AllowEmptyInput or other tricks, but noone does that without a good reason.

I know that even using xorg.conf is not necessary these days, but I had to do it to fix my original problem with keyboard and touchpad not working. I had to turn off AllowEmptyInput which really helped but probably caused the weird keyboard issue…as you’re writing. I suppose there’s a underlying problem, which should be fixed properly instead of using tricks like AllowEmptyInput but since everything is working just fine I’ll keep it that way until it breaks again or I have more time for that.