Is the one-click NVIDIA install surely working OK?

Hi. I installed opensuse 11.1 on my computer few months ago, and using vesa driver straight after installation made the system look awful - the screen geometry and aspect ratio were completely broken, and system refused to set bigger resolutions. I used one-click install from here (for the appropriate model, of course):


ASAP. I have 8800 GTS 512MB card. After rebooting, I was greeted with command line interface saying there was a fatal error when trying to start X server - ‘couldn’t load module ‘nvidia’’ was the cause, AFAIR. I needed to boot to failsafe mode, when I searched for ‘nvidia’ in YaST. I found out, that I had x11-video-nvidiaG02 installed (seemed fine) and nvidia-gfx02-kmp-trace
Now, I am not a very big linux power user, but I think there are several kernel types, and trace isn’t the one ‘normal users’ use. I deleted the trace one and chose to install nvidia-gfx02-kmp-default. System worked perfectly fine after that.
I ignored that fact, hoping somebody else would fix this instead of me - the NVIDIA site in opensuse and it one-click install will be something many users use, right? Well, it apparently seems not. I reinstalled my system today only to find it unfixed, I recalled what I did the previous time and it works fine as it did before.

So, will somebody fix it and make one-click install point to ‘default’ kernel version driver, instead of ‘trace’ ?Ia m sure not many newbies would be able to find out what to do in such situation, I solved this issue more than by luck than by knowledge, I must admit.

Thanks in advance!


you are right, there is more than one kernel “type”. there is the “vanilla” is the kernel developed by Linus Torvals on “default” is the “vanilla” kernel with patches (mostly addional drivers) from openSuse. while the “trace” kernel is a real time kernel, it includes different patches mostly to the vanilla kernel, but also includes changes from the openSuse team (if its the version from suse servers).

however i, too, have a Nvidia card, the 8800GT. i never expirenced any problems, altought i have all 3 kernels installed (vanilla, default & trace) with different versions. none of them limited me in any kind, i was always able to use the nvidia drivers even on games like Star Trek Armada II.

so please give us the output of the following terminal command:

rpm -qa | grep kernel

This is a semi known problem but seems difficult to track from the little I’ve seen mentioned of it. You’re the first I’ve seen with it :wink:

As the above post match kernel to nvidia patch.

If you can replicate it most of the time I would expect they would appreciate a bug report.

For my two tries with installing opensuse 11.1 and the using one-click install, both failed and I was greeted with commandline and needed to manually fix it in YaST in failsafe mode.

warnec@linux-l87q:~> rpm -qa | grep kernel

Note - this command was executed after I started to update my system, so it may contain the new kernel update from opensuse repos (I had the message that new kernel will be activated after reboot)

The same goes to kernel headers - I am installing all packages which let me compile programs in future, so headers weren’t present for the first time I installed opensuse.