is the intel driver busted in 11.0.xx?

openSUSE 11.1 alpha3plus
kernel 2.6.27-rc5-git9-6-pae
KDE 4.1.66 (KDE 4.2 >= 20080912)) “release 2.1”
xorg 7.3/7.4
intel i845g onboard chipset
sceptre x20wg - naga ii (1680x1050) lcd monitor

my intel driver has apparently been busted for several weeks. (at least i think the intel driver is the culprit).

i did an update one day several weeks ago & rebooted then my xserver would no longer start. i would get either a blank screen or a screen with static & colors.

i have tried everything one could possibly think of but the xserver simply will not work correctly with xorg 7.3 or 7.4 with the intel driver. (i get the same result mentioned above with 7.4 that i did with 7.3). i also tried the i810 driver but it spits out a bunch of stuff but the relevant part is at the end where it is “no screens found.” i have hacked the xorg.conf file every which way too to no avail.

i figured this could have been a configuration problem so i reinstalled openSUSE 11.1a2 and to my horror the problem was still there. (i burned the dvd at the lowest possible speed & verified the written data. i also did a media check with the dvd before installing & that was fine too). so i upgraded to 11.1a3+ but that didn’t help at all.

i’m trying to get 1680x1050 @ 60hz but i can’t achieve that. i tried patching a modeline with 915resolution even though i know it isn’t necessary with the intel driver any more but that didn’t work either. i have tried specifying (correct) modelines in my xorg.conf & not specifying modelines but neither appeared to make a difference.

i also tried booting up the latest kde four livecd & configuring the relevant hardware with sax2 (gui) & saving the xorg.conf & then trying to apply the livecd’s xorg.conf to my 11.1a3+ install but that didn’t work either. (i figured i’d try it since the kde four livecd works just fine). running sax2 -a from failsafe command line doesn’t work as it just cycles (or scans) through video modes & always leaves me with a blank screen that i either have to ctrl+alt+del or hard reboot out of.

here is my xorg.conf:
general pastebin - Mine - post number 1205936

here is my Xorg.0.log:
general pastebin - Miscellany - post number 1205950

i noticed this line in particular in the Xorg.0 log but i don’t know what it means:
(WW) intel(0): Bad V_BIOS checksum

all this leads me to believe that the intel driver is busted somehow.

i am running with the vesa driver right now. i might just use a livecd again for a while until this get resolves if it will take a while.


On Fri, 19 Sep 2008 16:56:02 GMT
echoes- <> wrote:

> [snip]
Since it looks like you are running an alpha version, have you
submitted a bug report on it?

no i have not. you are right, i should. i’ve just been so busy getting my system back up & running that i haven’t had time to do it yet.
i will once i get the time.

i’d like to get other confirmations or denials first though…

i forgot to add that i find it extremely hard to believe that someone would have totally obliterated a driver & at least one person would not have noticed it and said something for almost a month.

any way, i filed the bug:

I have the same problem and i use 11 stable version and it happened to me the same way as you ( you know : messed up login screen and statics and…) and updating xorg to 7.4 didn’t worked either so i fixed it by downgrading to dvd version of xorg repository

and for the record i did post a topic for help

xorg gets messed up at login :(( - openSUSE Forums

the relevant bug (which i filed) is here:

However, this bug does not affect most older onboard Intel gigabit adapters, which still use the older e1000 driver (such as the one included as part of the 865PE/875P AGPsets). Because there is an overlap between the original e1000 and the e1000e (which appears to be the original e1000’s direct successor), it would help to clear up which Intel products actually do use this driver (and which do not). I have an ASUS P4C800-E Deluxe with the 875P AGPset and onboard Intel gigE; however, it uses the original e1000 driver, not the bugged e1000e (and works just fine with this kernel).