Is the Intel® Core™ 2 Duo P7370 (2.0GHz) 64 bit?

Thanks for the wealth of info oldcpu, including your take on the graphics. I’ve been going through various HCLs since you posted – and looking for a 15" laptop with similar specs to the HP at a comparable price. It’s pretty difficult to find a comparable value for money lappy in my wholesaler’s stock.

I only have two reservations now – the size (of the screen and of the 3 Kg weight) is one and the other is the wireless - although if HP recommend SLED, wireless would be OK.

I’ll wonder on for a bit longer.

I bought HP Pavilian dv4 (screen 14.1, 2.3kg) last week.
Inter centrino Core 2 Duo(P7350 3Mb cache 2.0Ghz)
Intel Wifi, Gigabit ethernet, Hp webcam, 4GB RAM, 320GB hdd.
Even it is not listed in the HCL. But most of the hardware works in 11.2,11.1. Just except fingerprint,bluetooth. Installed webcam and working. I think, i need to find drivers for finger print and bluetooth.
Wifi,ethernet is working like a charm.
Sound is still a mystry and working on it to sort it out.

Now, which one…either 32 or 64bit. I installed both on this laptop. And i am amazed how fast it was on 64bit. Much faster than 32bit in even opening simple applications.
I prefer to use 64bit onwards.

Well I bought the HP ProBook 4710s. I assembled the machine, popped in Ubuntu 9.04 live and the wireless “just worked”, attached the NET straight off. Impressive. How relieved was I!!!

But I don’t want Ubuntu, just openSUSE. I installed 64 bit openSUSE 11.1 Gnome, added the ATI repos, installed the 6 months worth of standard updates from the update repo.

And the ATI video “just worked”. And sound “just worked”. The wireless NIC just worked and Gnome’s NM invited me to insert the connect code to attach to the LAN, which worked. The NET just worked.

I’ll never use 32 bit again; Linux has come of age, leaps and bounds ahead of my first experience with SuSE Linux 10.0.

It’s a fast machine. Full size kbd is a boon. The Fn+F5 key to suspend the computer “just works”, and so on and on.

I’m glad I chose to pay the extra $300 and get the HP rather than the Acer. HP said Suse would work, and it does.

Plenty more to do yet, like the webcam, the fingerprint thing doesn’t interest me, figure out power management etc etc etc, but I think I can retire my old desktop to a role as a family server in a few weeks.

To all who commented during my thinking about this purchase – thanks a heap!


I am still sorting out the finger print issue.
But for web cam you can follow this page, its easy to install.

UVC Webcams - openSUSE

Hope, it works for you.

Fantastic ! I’m also a converter to 64-bit, and happy about the conversion.

A favour - when you get the chance in the next few weeks, could you update the HCL ? I started an entry here for your HP 4710s: HCL/Laptops/HP - openSUSE

I’m thinking we may also need to split that HP page in two … as there are too many entries

Thanks for that advice. Tried it out and it works fine.

I will – started already after mmarif4u’s tips worked for the webcam.

Further discovery: My goodness, Gnome and openSUSE really have come of age.

Out of curiosity I switched off my home networking and plugged in my mobile wireless broadband dongle that I use while traveling. It’s quite a to-do to get it working in KDE. In Gnome it just popped up in the Network Manager in the Panel. Add the *99# connect code, username and password and bingo → on the net with HSDPA/CDMA (or whatever it is) wireless broadband.

Network Managers is one of the absolute key apps for an operating system. If it doesn’t “just work”, joe public can be so unforgiving (and rightly so). I’m more and more impressed with Gnome every day.

I hope, there will be also a page and entry for HP dv3,dv4.
@swerdna: BTW, if you find any clue for finger print and blue tooth, please let me know. I will be thankful.

Maybe oldcpu will start one for you to put the results for your dv4 in there.
@swerdna: BTW, if you find any clue for finger print and blue tooth, please let me know. I will be thankful.[/QUOTE]Sure – I will let you know when and if.

OK I tried bluetooth and it worked OOB. The bluetooth icon was in my systray/panel in Gnome. So I enabled bluetooth in my phone. Then I clicked the bluetooth icon and chose “set up new device” and I saw my phone in the lappy window and followed the bouncing ball. Then I browsed the files in the phone – works OOB in Gnome.

Ohh…it works for you in Gnome. Good. I am using KDE, just updated to 4.3. I used kbluetooth4 in kde4.1.3 and it never open any window for me. I know, that all the drivers are there and installed. Need an application to sync.
Which application you are using in Gnome for bluetooth?

I put a placeholder for HP DV4: HCL/Laptops/HP - openSUSE

I can’t put any more in, as I am late and need to rush to work.

I have bluez, bluez-gnome and gnome-bluetooth. The last is the one that puts up the GUI I spoke about.

I tried out bluez. kdebluetooth4 is the default app in kde i think. Its not going to open in any situation.

I start bluetooth demon and then scan the for devices.

linux-aqc9:/home/anl # hcitool scan
Scanning ...
        00:21:FC:D4:8C:D3       Nokia 2680s-2

But if i do scan from my mobile, it says “No device found”.
Any idea about this?

About the dv4 in HCL, can i provide any information to put there? because the wiki looks like confusing for me. Thanks

I got bluetooth working under Kdebluetooth4. I just delete it through yast and reinstall it from yast. And it works.

Now is finger print…!!!

Please check here to see if I have the HCL entry for your HP dV4 correct:
HCL/Laptops/HP - openSUSE

I might have to mark the sound as strange – but I’ll ask in the correct forum first

Thanks oldcpu for the HCL entry. All entries are correct just except the sound one. By default sound will not work after installation. We have to tweak it. Like as we discussed it in this thread.
Sound issue – Intel Hda - openSUSE Forums
For webcam have to follow this page to get it working.

Power management is also working fine.

Thanks again for your time to put it in the HCL.

Thanks . HCL updated again.