Is solution for following bug in Virtual box is available

I use opensuse 11.3 64 bit with kernel Linux x86_64 as whenever I start my virtual box(VirtualBox-3.2-3.2.12_68302_openSUSE113-1.x86_64.rpm)
though it works fine but shows this bug warning image
how to solve it?

Do what it says? Disable Host I/O cache in the settings for the VM, under Storage.

is this is the host it is already checked
I unchecked it too but error is coming
does it need a reboot?

I don’t know then. Try asking in the VBox forums.

one thing more how to change the guest os from 24 bit to 32 bit mode actually my win 7 is 32 bit but the display setting is 24 bit mode though a message says you can adjust the dislay in the host settings where it is? does it come after installation of host os…

Well the bug is the ext4 File system. If you are using the SATA controller and do not have the host I/O cache enabled it corrupts the drive. Nasty little thing that has been reported to the kernel people but not resolved yet. If you host is using the ext4 FS I would strongly suggest that you make sure that it is enabled

As I learned goggling…
But there can be a solution if one of your partition is not ext4 its like NTFS or something then use that medium to save image of (future)guest host