Is opensuse 13.2 kgpg broken or is it me?

My situation is that I have used kgpg successfully in openSUSE 13.1, but not at all in 13.2. I have the two distros in a dual boot on one hard disk. I even did a new clean install of 13.2 but no luck.

In openSUSE 13.1 my kgpg encrypted files have the property of Type: PGP/MIME -encrypted message header. A file encrypted with 13.2 kgpg has the property of Type: plain text document with contents PGP/MIME-encrypted message header. Both have the .asc file type.

The file that I encrypt in 13.2 then cannot be unencrypted by means of “Actions>decrypt.” This function is not in the context menu. It’s just not available.

Also, when I look from my openSUSE 13.2 Dolphin file manager at my encrypted files in openSUSE 13.1 they appear as Type: plain text documents. So not only is kgpg having problems, but Dolphin also in that it sees all encrypted files in another OS as plain text documents.

I have checked the forum and cannot find that anyone else has reported this kind of behavior, I even checked in Ubuntu. I did find that LinuxMint KDE with kgpg works without this problem.

Any thoughts? Do others have openSUSE 13.2 kgpg working correctly?

It’s a mystery to me. If anyone has a solution I would appreciate hearing from you.



Something is messed up, but possibly not kgpg.

I just looked at two files with dolphin. Both are actually encrypted email messages.

The first is my copy of sent mail. The second is received mail.

Dolphin showed the first as a plain text file. Then is saw the second as email, and started “evolution” to read it. But I am using KDE, and I have “claws-mail” configured as the application to handle email.

I would do some tests with “kgpg”, except I don’t normally use it so I don’t know what is normal.

Have you tried “kleopatra”? That is probably also installed.

OK. Thank you nrickert (aka Flux Capacitor Penguin) for the tip to use Kleopatra. GPG worked just fine when I used Kleopatra. :slight_smile:

I still think that there is a problem using kgpg. Perhaps I will file a bug report.

Will the Moderator please mark this thread Solved. Thanks.


That “flux capacitor” stuff is just a tag that the forum add for people with as many posts as I have made over the years. That forum “feature” is also what shows you as a “Newcomer”.

GPG worked just fine when I used Kleopatra. :slight_smile:

I’m glad to hear that. It’s my impression that “Kleopatra” is more fully functional than “kgpg”.

Perhaps I will file a bug report.

Yes, you probably should.