Is openSUSE 11.1 PPC busted?

Or are there any forum regulars using PPC linux here? My hardware is an iBook G3 600.

First of all, the HAL daemon on openSUSE 11.1 PPC seems to be misconfigured in a way I don’t know how to fix. It starts with the installer and stays that way in the installation. It’s so bad that the installer DVD will fail to recognize itself during installation, so the installation fails. You can go into console and manually start up hald, but the problem lingers on.

Updating a perfectly working openSUSE 11.0 PPC to 11.1 with the installer DVD was a bust. It seems something in the bootstrap partition got messed up that the system became unbootable. The choices seem to be to stay with 11.0 or install 11.1 from scratch.

However, with hald misconfigured in a way I don’t know how to fix, I can’t attach a FireWire or USB drive and have them show up. The same goes with a DVD or CD-ROM. Fine, I can manually mount those from a command line. But when I want to add a package from repository, the first repository openSUSE looks for is on the DVD. Which it can’t find, because the system can’t recognize the DVD. Well, fine, I can still copy the DVD repository onto the hard drive or change the repository path manually.

Now, there’s a minor amount of witchcraft involved in getting ppc linux installed on an external drive. However, when there’s an external USB or FireWire drive attached, it seems there’s no way to get the installer to recognize the repository on the DVD. So here’s another install bust.

Is there anyone around here to share this experience?

Yes i have the same problems.

Tried a clean install but ended up with the same. The installer runs into the problem of not being able to mount the DVD whatever I did (and yes, it was fine with 11.0). So i as well tried an update which f*cked up my entire system. Now i can only step back to clean install 11.0 and customize and tweak again. >:(

I thought to do that with a “better” 11.1 … failure :’(

How was that? Never change a running system.

openSUSE 11.1 - Repositories?! - openSUSE Forums

On some of the development lists, there’s someone with PPC board who complain about bloat & performance issues, but without localising problem.

Have any of you put in reports on PPC to Bugzilla? If all PPC users left aren’t active in the community, I guess PPC will become less and less functional.

You really should plan for upgrades, having a backup. PPC just seems to be less and less popular (did Apple jump ship or something?) so PPC is not getting the testing that i686 / x86_64 receives, and those architectures folk were disappointed because the release didn’t have enough fixes.

A shame! OpenSuse is my fav distro on all machines I suppport and so i wanted to use that PPC as well on the needed machines. Seems there is a need to switch to Yellow Dog if Novell decides to let ppc version go down the drain.

openSUSE is a community. It’s not “Novell” alone who can produce the distro and do all the QA. Using 11.0 and filing bugs against 11.1 might help find out, if PPC is getting good support from paid engineers.

If you have a mix, then may be taking a look at Debian “Lenny” would be an option if OS 11.1 & beyond don’t get sorted.

Yes I understand that OpenSuse doesn’t equal Novell but they hold the money, which I guess, puts them in the drivers seat, no?

Anyhow, let’s talk tech and not politics :wink:

I tried different distros, maybe I am wrong but to me Debian has some rough edges… nothing I could proof by facts, just emotions, while YDL seems somehow driven by a very small community but its not driven bad from the Apple PPC perspective. Well i had log out problems with E17 but hopefully they got that known issue solved out meanwhile :wink:

If there’s an active openSUSE community around PPC, then Novell would find it hard to drop. OTOH if noone is involved, then PPC becomes more and more of a problem to support well.

I tried different distros, maybe I am wrong but to me Debian has some rough edges… nothing I could proof by facts, just emotions, while YDL seems somehow driven by a very small community but its not driven bad from the Apple PPC perspective.

Can’t try Debian on PPC, but the i686 Lenny release seems very solid, and they do have an active PPC community, and also groups using older equipment. They only dropped i386 when gcc, failed to produce compatible code, long after big distro’s had made pentium a minimum requirement.

YDL as specialists, may benefit less from work done by ppl in other popular architectures, and obviously if you have intel to, you have no choice but to be heterogenous.

But so far openSUSE supports PPC, though the overwhelming majority of folk on development type lists are running x86, which has follow on consequences.

We have a different perspective in that. IMHO a good product pulls customers/community to a company and not the other way around. So if OpenSuse/Novell (i know, i know) would be interested in the PPC, people now running Debain or YDL could be attracted and this would build the community by itself – that especially counts as for the synergy running it on a PS3 (see YDL). But again, politics is not the issue here.

Seems that loosinghair found some kind of a workaround to it which I will try today … or so :wink:

SuSE has been a good product for PPC in past. 11.0 is still available, but you must know that PPC is losing market share, so relying on other ppl to find all the problems, is going to become less and less viable. Fewer and fewer, haven’t “upgraded”.

@ loosinghair
Now I see, I referred to a post where you yourself mentioned a workaround. Why then opening a thread again?

http://forums.opensuse.org/install-boot-login/402570-opensuse-11-1-repositories-3.html#post1937522

I like that spirit. Let’s talk tech and not politics, that is.

However, if Debian is where the active PPC Mac linux community is gravitating towards, I might have to investigate using that myself.

I haven’t filed my case with Bugzilla. It’s been a while since 11.1 was released, and if this isn’t a well-known problem, then I guess openSUSE PPC Mac users really are few. (Who’s active enough to be maintaining the port in that case?) If I have to be personally active to see openSUSE continued to be maintained for my specific hardware, that is too much commitment for a hobby, though.

I posted a new thread because I realized the problem affects more than just the installer’s ability to access the repository. And a workaround that worked for me is just a workaround. It doesn’t address the issue of what broke in PPC Mac openSUSE 11.1 PPC Mac.

I’ll be doing a few clean installs of 11.1 to figure out what the exact problem is myself. One of the more important qualities of a bug report is consistent reproducibility.

Some of them just aren’t though. There is a problem, but it takes a number of ppl being hit before a pattern becomes clear.

To me the workaround was to make a network install happen, which is indeed not a real solution… so slow. Anyway I have it up and running now, but other issues appear (sound not working). Anyhow I’ll tame the beast :slight_smile:

Next step, trying to install the sounddriver in GNOME gives me the following error

Das Kernelmodul snd-aoa für die Soundunterstützung konnte
nicht geladen werden. Ein möglicher Grund dafür können falsche
Modulparameter sein, sowie ungültige IO- oder IRQ-Parameter.

The kernel-module snd-aoa for the soundcard support could
not be loaded. A possible reason for this could be wrong
modulparameters as well as an invalid IO- or IRQ-parameter.

Can anyone help?

Sorry wrong thread.

For the ones searching for the solution… maybe that helps

openSUSE 11.1 - Repositories?! - Page 3 - openSUSE Forums