Is Network Manager wrecking the routing table?

Up until recently I’ve connected my two desktop PCs (see below) to the router by ethernet cable. I decided to move the router to a different place in the house and switch to Wifi. To do this I’ve attached a Linksys WUSB54G network adapter to each PC which use the RT2500USB driver.

The new layout works well with ifup but I wanted to use Network Manager, unfortunately I get a problem with that, having done the following.

I go into Yast>network_settings and switch from ifup to Network Manager, then install the NM widget on the task bar. After that, setting up the NM config in “Managing Connections” gets me to the point where everything works just fine and I can access the internet.

The problem comes after I either reboot or sleep/resume. The connection to the internet is no longer working.

After a lot of playing around, I find that the IP routing table (in /sbin/route) is being modified during reboot and ends up with the single line for Destination and User Iface lo. All the wlan0 entries have gone.

This is very puzzling. In NM config I choose the “Unencrypted file” option for “Connection secrets” which I think is recommended.

I’m running 12.2 (64 bit) with Kernel 3.4.11-2.16 and KDE 4.9.3 release 5

I also have a Samsung netbook running 12.1 and it has exactly the same problem with the routing table.

Any ideas for getting round this problem gratefully received.

This is npot a very helpfull answer, I know but

The new layout works well with ifup but I wanted to use Network Manager,


Ha - I wondered if somebody would ask me that! I guess the answer is just that it’s what I’ve used in the past - and you get an indication on the task bar if it’s not working ok. Maybe you can do that with ifup but I don’t know how to.

The other thing is that, if I know something isn’t working, I like to know why. :shame:

I’ve just found that my spare HDD with 12.3 M1 also has this problem.

I do not know what “past” you are talking about.

But you may have forgotten that in Unix/Linux there is a big difference between the user and the system manager. Normaly the system manager is responsible for configuring the system correct. The user only has to use it. (S)he has not to worry about network connections and other underlying hardware. The silly NM applet is only there to accomodate users that travel around with their system and must make a choice of available connections themselves on e.g. airports (because the system manager is not there, or at least not easily available).

Never in my live as an end-user on many, many systems (not only Unix/Linux) I ever had my screen space spoiled by an icon that I should use to see if my network connection was functioning (nor if my disk was revolving, nor …). Only when the system did not function, I went to my system manager (which may be me again!) and the system manager then has his/her own way of testing, configuring, managing the system (as root).

Unfortunately the silly NM applet you mention is what makes an operating system useful on a laptop - and laptops are usually purchased to do computing on the go. My recommendation to the OP is to stick with ifup for the desktop machines because a static connection is the most suitable for desktops. As for the Samsung laptop, I think it’s worth persisting with NM so one can change the wireless connection on the go. You can update to 12.2 but my guess is that it won’t help. I too have experienced the need to reconfigure wireless routing after every reboot and perhaps this should be posted as a bug. Thanks to the OP for alerting the cause to be a change in /sbin/route file. A haxxy workaround (which I guess no-one else here would approve of) is to reverse the effects of the routing changes in the after.rc file (a script that runs after establishing a runlevel).P.S. On a note of caution - I would advise at least ONE of your desktops to be hard-wire connected to your router for online purchases in which you enter your credit details. Many have told me this is neurotic and unnecessary but I can tell you (because I’ve seen it) that information sent over any WPA/WEP connection is not secure.

Install “rfkill”. You can then use that to see whether the interfaces have been disabled. The man page for “rfkill” gives the command options.

There might be BIOS settings for which devices are powered down on suspend, and perhaps that is related.

The NM applet has an option to disable/enable wireless. You might try disabling then re-enabling.

I have never seen the problem that you describe. On the other hand, I rarely suspend, but I do restart the system occasionally and WiFi connections have started without a problem.

IMHO tjhat is what I said, though in different wording :wink: Well, not the fact that it IS a laptop, but that is is an “on the go” triggers the need for NM.