is my hard disk failing?

i have a 1TB western digital portable hard drive. i have just tried plugging into suse machine…nothing. i have just tried plugging it into another machine, which has windows on it…nothing. the drive light comes on and i can hear the disk spinning.

any thoughts?

this will be my second WD drive to fail :mad: this 1TB drive has nearly 800GB of stuff on it, most of which is backed up…but that’s not the point is it.

cheers for any responses.

Do a smartctl test should tell you more.

also, to see if it is recognized,open a console,su to root & type:

**tail -f /var/log/messages **


thestig wrote:

> any thoughts?

When it’s physically attached to the OpenSuSE box, what’s the output
of ‘fdisk -l’? Do you see a /dev/sdb or the like with the approximate
size? This might tell us if the device node(s) are being created for it.

Menes Narmer
menesofmemphis [at] gmail [dot] com

“Unity and humility is the lesson all of history teaches.”

Try plugging it in when the machine is off > boot into BIOS > see if it is shown there

See if any thing usb is turned off in bios; turn it on

Continue the boot watch the scroll & see if it is detected (prior to the bootsplash)

Then see if it comes up in the OS.

Before you trash it, run some OEM utilities on it & find out (e.g., you may have lost the partition table).

well, this is very strange indeed. it turns out someone dropped the drive. i unplugged the drive. ran the tail command to show logs, it showed several (i didn’t count, roughly 6-7 though) lines of the device giving I/O errors at sector x (where x is a large number). i then replugged the device and it connected fine and showed. to start with it was not appearing in /dev as normal as /dev/sdb1. i opened some stuff and some files would not work (i thought maybe corrupted) but i unplugged it then replugged it and all data seems fine :confused:

however, one thing puzzles me a lot, a friends pc on windows simply detected the drive, and that was it, it did not install the drivers, i could not read the drive, in fact, no windows pc seems to (i have tried another vista machine without success); so the only machine which is able to read (and write) to the drive is my own suse linux box - which is windows free of course.

why on earth could only suse see and read/write from it? this is so strange, maybe you clever people have some ideas.




When a drive is powered down normally, the search arm is supposed to move to a park position and not be out over the disk platters.

That is supposed to preclude normal movement from allowing the arm to contact the platters.

So, the damage may depend on when it was dropped.

I’d recommend getting the OEM’s utilities and at least checking for bad sectors, etc. Their software may be able to isolate the bad parts/sectors & you can go from there.

The 1st thing I would do though is copy off any needed “stuff”.

If you have an old Hard disk laying around, get it up in “fstab” & copy your stuff over.

Good luck.

Hi Snakedriver,

thanks for getting back. i believe the drive was turned off when dropped; i definitely know it was not connected to a machine, but it may have been plugged in. how do i run a disk check, from what i used to think the best way for disk check is using the install dvd, but on 10.3 i believe this is broken? are there any command line tools (or GUI??) which i can use once i use umount to unmount it, as it’s probably best to scan the drive whilst unmounted.



Hello Ross,

Did not recognize you, where is your avatar?

You don’t have problems with your disk again have you? A lot off people, including me, had a hard time during your earler loss!

ah, will upload the avatar soon, forgot about that. not similar problem, that last one was a good drive, but it got locked out badly. this one, someone dropped it and it only seems to work under linux. not too much of an issue as i only use linux now, but if a friend of mine wants to borrow some stuff etc they can’t. new drive ordered at the expense of the person who dropped it lol.

which avatar to load…the linux inside one or the old tux doing something to a windows logo…hmmm lol

nice to see you here hcvv.

done hcvv, used the old avatar from which i had.

see you around,


Welcome back thestig. I am glad to hear that this time the money has to come from another person.

List the drive’s make & model. We can find the OEM utilities on floppy or CD most likely & run those from a cold boot.

BTW, I always go back to the OEM as they most always have new S/W tools up:)

the drive is here Western Digital My Book 2 Essential 1TB USB 2.0 External Hard Drive: Electronics & Photo

it’s not too much of an issue now since the person has ordered a new one for me, so since i can still use it for linux, i can transfer my stuff onto the next one hopefully. but…before i do so, what do you guys reckon regarding format? it comes as fat32 but…well that’s not that great, should i stick with vfat, or go ext3?

hmmmm. cheers for the help guys.

If you’re not going to use the drive on Windows, I’d say definitely choose for Ext3.

benefits of ext3 are…? i know the FS doesn’t fragment as much but don’t know about too much else really. thanks MC, good to see you here too as well :smiley:

something to read :wink:

EXT3, Journaling Filesystem
ext3 - Wikipedia, the free encyclopedia


thanks Andy :smiley:

think i’ll format it to ext3 and take the plunge

Actually it’ll be wise to choose your FS based on usage. For example, if you’re going to store lots of big files on it, then I’d suggest using XFS as it can deal better with those files than Ext3 can. XFS is also generally faster and has a lower fragmentation level than Ext3. Also XFS has a higher throughput than Ext3.

FAT32 is common on external drives. It may be for broad compatibility, but I’ve also seen software with such drives which only supports FAT32. In my experience - YMMV - it’s not been a problem reformatting with another filesystem, but you may lose the sw utilties that came with it. The biggest pain with FAT32 is the 4GB file size limitation. With a 1 TB drive, on some Windows systems in order to see the entire drive or even to just recognize it, can require an oem driver or a drive overlay.

If you want it usable with both Linux and W$, you can format it as NTFS on a W$ machine and then on SuSE use the ntfs-3g driver. If you will only use it on Linux, and you will not have a lot of very large files, ext3 is probably best.