Is kOrganizer ical import broken in 42.3?

Well, which version of korganizer do you have in the 42.2 install?
Is it 4.x or 5.x?
That might explain some differences.

I’m pretty sure that config module should not be in a default Xfce install though (also not in 42.2), neither the KDE4 one nor the Plasma5 one.

Interesting, I have just gone through the Xfce settings and find nothing for changing User locale, etc. The only places that even give a choice to choose time zone is the Yast Date and Time module, and in the Orage Calendar itself.

If there is no desktop specific setting, you would be using just the system ones, set by YaST.

I don’t think YaST offers fine-grained options here (e.g. different time locale if you wanted that), but you can also edit /etc/sysconfig/language yourself (with a text editor or via YaST->System->/etc/sysconfig Editor).

The only real reason why I prefer British English, despite having spent more than a few years working for US American companies both in the UK and here in Germany, is that, “it’s the English I learnt at school” (NZ English didn’t exist then). :stuck_out_tongue:
[HR][/HR]“God save the Queen”; “God of Nations at Thy feet”; “Land of hope and glory”; “Jerusalem”; Byron, Hardy, Dickens and all that stuff . . . (Shakespearean English doesn’t count – that’s only for the stage and practising pronunciation . . . >:) )

Yes, it is 4, which I already surmised. Just checked before answering, though, and confirmed that. I note now that there are two choices in 42.2, korganizer or korganizer5, but only the one choice in 42.3.

But, I already thought that was the case, and I am bringing this up in case something has been changed inadvertantly. On the other hand, the change might be intentional. When I finish with this, I should know if I should submit bug reports, or a bug report, or … ?

I’m pretty sure that config module should not be in a default Xfce install though (also not in 42.2), neither the KDE4 one nor the Plasma5 one.

Yes, I would think. However, it is pulled in and at this time I do not know how. QT? (There is a QT setup module in Xfce). One of the other KDE applications I have? Although, I have the same apps installed on both machines, so something pulled it in on 42.2, but not on 42.3.

If there is no desktop specific setting, you would be using just the system ones, set by YaST.

Yes, which I have set to Vancouver time in the Yast module. However, exchanging the ics file between the two machines, the 42.3 converts everything to UTC from Vancouver time, seriously messing up the Schedule. I find no setting to change that.

This does not happen exchanging the data between kOrganizer on 42.2, kOrganizer on 13.1, and Offline Calendar Import connected with Etar on Android.

… but, the ics import problem is solved, though not yet perfected because of the time-zone problem.

When (in 42.3 with kOrganizer5) I click on Settings=>Configure Date and Time, I just get the error I mentioned before. That should not happen, should it? I would expect it would call up something other than an error, if it is bug free.

I don’t think YaST offers fine-grained options here (e.g. different time locale if you wanted that), but you can also edit /etc/sysconfig/language yourself (with a text editor or via YaST->System->/etc/sysconfig Editor).

Yep. But, language is no problem here, U.S. English is okay overall.

'Tis better ye speaketh plain by that which ye knowest, than to espouse gibberish by that ye knowest not.lol!

Is the system time of all the machines “UTC”?

  • AFAIK, for the case of a KDE user’s GUI, the user’s physical location on the planet Earth and, the resulting Time Zone, also needs to be setup (on a per user basis) in the KDE “System Settings”.

Leap 42.2 machine time: UTC; KDE user interface set to Berlin - Germany - MEST (UTC + 2); “/etc/localtime” is a link pointing to “/usr/share/zoneinfo/Europe/Berlin”.
Looking at the .ics file of a recent KOrganizer appointment, I see the following in the time stamps:


 > ls --full-time libkcal-2139650253.583
-rw-r--r-- 1 dcu users 3262 2017-09-17 11:24:51.286767217 +0200 libkcal-2139650253.583
 > TZ=UTC ls --full-time libkcal-2139650253.583
-rw-r--r-- 1 dcu users 3262 2017-09-17 09:24:51.286767217 +0000 libkcal-2139650253.583
 > 
 > grep '2017' libkcal-2139650253.583
DTSTAMP:20170917T092451Z
CREATED:20170917T091501Z
LAST-MODIFIED:20170917T092451Z
DTSTART;TZID=Europe/Berlin:20170918T200000
DTEND;TZID=Europe/Berlin:20170918T213000
 > 

Summary:

  • The file’s indicated
    timestamp is ‘11:24’ (MEST); the file’s UTC time is ‘09:24’. - The ‘created’ and ‘last-modified’ timestamps within the .ics file are UTC: ‘09:15’ and ‘09:24’ – DTSTAMP is also 09:24’ UTC.
  • The appointment start and end times are however Europe - Berlin - UTC + 2: ‘20:00’ and ‘21:30’.

From what you’re saying, Leap 42.3 seems to be messing up the information in the “DTSTART” and “DTEND” fields.
[HR][/HR]I’ll check later with some more Leap 42.2 (and older – 2012 – SuSE ??? – KDE KOrganizer very old) appointments exported to my Leap 42.3 machine.
Must say that, I haven’t, to date, noticed this issue on the Leap 42.3 machine – on the other hand I haven’t really checked in detail, yet . . .

Yes, kdepim4 has been dropped in 42.3.
The last upstream release was over two years ago…

But, I already thought that was the case, and I am bringing this up in case something has been changed inadvertantly. On the other hand, the change might be intentional. When I finish with this, I should know if I should submit bug reports, or a bug report, or … ?

As I wrote, you can file a bug report about the missing kdepim-runtime dependency (already fixed in Factory), but not for this.
I don’t think it makes sense to pull in the whole Plasma5 desktop just for KOrganizer, and as mentioned it won’t help anyway as that settings module will only configure the Plasma5 desktop and have no effect to your XFCE session.

Yes, I would think. However, it is pulled in and at this time I do not know how. QT? (There is a QT setup module in Xfce). One of the other KDE applications I have? Although, I have the same apps installed on both machines, so something pulled it in on 42.2, but not on 42.3.

It’s part of the package kdebase4-workspace-addons.
AFAICT this is only pulled in by kdebase4-workspace, the KDE4 desktop.
If this was an upgrade (from 13.2 or earlier), it won’t get uninstalled automatically though.

Yes, which I have set to Vancouver time in the Yast module. However, exchanging the ics file between the two machines, the 42.3 converts everything to UTC from Vancouver time, seriously messing up the Schedule. I find no setting to change that.

Might be a bug, yes.
I even remember a report at bugs.kde.org about some such problem, have to search for it.

Could you maybe provide the file?

Also, just to be sure, what’s the output of “locale”? (run as user)

When (in 42.3 with kOrganizer5) I click on Settings=>Configure Date and Time, I just get the error I mentioned before. That should not happen, should it?

So it should silently fail if the config module is not installed?
I don’t think that’s a good idea either. :wink:

And checking if it is installed (and disable or remove the option if not) is probably not easy to do either (in a distribution agnostic way, installation paths may be very different, if you compile from source you can freely choose them anyway…).

On Leap 42.3.
Via KDE System Settings, changed the Laptop’s Time Zone – from Berlin to London, and then to Dawson.

The Appointment time displayed was always the Laptop’s local time.

  • When editing the Appointment, the time displayed was, mostly, UTC and, by repeated change to Berlin time, save, and then close, on reopening the Appointment for editing, the displayed time was, once again, UTC.

So yes, a KOrganizer version 5.5.2 Bug Report is, IMHO, needed.

Thank you, again, for taking the time to reply, Wolfi.

Yes, I was thinking that, and I was thinking the problems had to do with the changes.

As I wrote, you can file a bug report about the missing kdepim-runtime dependency (already fixed in Factory), but not for this.

Yes. I plan to file one when I finish checking what else is related.

I don’t think it makes sense to pull in the whole Plasma5 desktop just for KOrganizer, and as mentioned it won’t help anyway as that settings module will only configure the Plasma5 desktop and have no effect to your XFCE session.

I have to agree with this. But, I will be making a suggestion (I guess, upstream?) that an option to choose preferred local time or UTC, especially on import, might be possible without invoking the Date module.

It’s part of the package kdebase4-workspace-addons.
AFAICT this is only pulled in by kdebase4-workspace, the KDE4 desktop.
If this was an upgrade (from 13.2 or earlier), it won’t get uninstalled automatically though.

Neither system is upgrade. Both are clean install to emptied (reformatted) partitions.

kdebase4-workspace and kdebase4-workspace-addons are not installed on the 42.2 machine, but kdebase4-runtime is along with kdebase4-workspace-libs, both of which I presume were pulled in as dependencies for at least one of the several KDE applications I have installed on that machine.

Of course, those are not pulled in on the 42.3 machine, because of the changes moving up to Plasma5.

I would guess that also pulls in the Date/Time module.

[QUOTE]Yes, which I have set to Vancouver time in the Yast module. However, exchanging the ics file between the two machines, the 42.3 converts everything to UTC from Vancouver time, seriously messing up the Schedule. I find no setting to change that.
Might be a bug, yes.
I even remember a report at bugs.kde.org about some such problem, have to search for it.[/QUOTE]

Okay, I will do a search. Of course, I have the Yast module set to Local time, but also have checked to have System time as UTC. I presume that is playing a part, & I will see if that is the case when I find the bug.

Could you maybe provide the file?

Also, just to be sure, what’s the output of “locale”? (run as user)

I could provide the file, yes, but only if you want to spend that much time analyzing this. I know you are busy, and I am fine without a solution to this, as I am currently using Lightning in Thunderbird on the 42.3 machine and that is interoperating just fine. When I do my full install to replace 13.1 on this machine, then I will be wanting kOrganizer, but I possibly will be installing the KDE team’s Desktop when I do that, so all will probably be fine.

I am now just exploring this to see if things can be made smoother for any others who want to do the unusual thing of running kOrganizer on an Xfce desktop (or other Desktop, for that matter).

But, I just ran locale and see quite interesting output:

gerry@FBAcerLtp2:~> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


:stuck_out_tongue:

So it should silently fail if the config module is not installed?
I don’t think that’s a good idea either. :wink:

Oh, yes, I definitely agree with you on this! Instead, I wonder if it could not at least pull something up, or be replaced in the kOrganizer configuration file with another way of choosing the time-zone for the application. Probably something for me to suggest upstream, as I said.

And checking if it is installed (and disable or remove the option if not) is probably not easy to do either (in a distribution agnostic way, installation paths may be very different, if you compile from source you can freely choose them anyway…).

This I suspected.

… and, again, thanks.

Thanks. Looking into it …

Ok, but the events in the ical file should normally specify the used timezone, AFAIK.
So there should normally not be a point in changing the timezone for the import (to UTC or whatever).

OTOH, it is possible to specify the timezone when creating a new event, also in 5.x.

Btw, found this bug report just now: 352509 – kOrganizer 5.5.x sends iCal events with times converted to UTC
But I’m not sure this exactly describes your problem.

kdebase4-workspace and kdebase4-workspace-addons are not installed on the 42.2 machine, but kdebase4-runtime is along with kdebase4-workspace-libs, both of which I presume were pulled in as dependencies for at least one of the several KDE applications I have installed on that machine.

Of course, those are not pulled in on the 42.3 machine, because of the changes moving up to Plasma5.

They are pulled in if you install a KDE4 application, also on 42.3.

I would guess that also pulls in the Date/Time module.

Well, I had a closer look now, and that module is actually part of kdebase4-runtime.

What probably confused me is that kdebase4-workspace-addons includes the systemsettings application

Btw, the KDE4 Date/Time module doesn’t allow to change the timezone at all though, just the locale and language settings, e.g. how the date/time is formatted.

Okay, I will do a search. Of course, I have the Yast module set to Local time, but also have checked to have System time as UTC. I presume that is playing a part, & I will see if that is the case when I find the bug.

You mean the hardware clock is set to UTC?
That doesn’t play a role here at all.

If you really mean the system timezone, then let’s check this:

ls -l /etc/localtime

and/or

timedatectl

I’m not aware of a user setting for this (and the date/time config module would actually change this system timezone, the KF5 version actually just calls timedatectl anyway).

I could provide the file, yes, but only if you want to spend that much time analyzing this.

Well, I could at least try if I can reproduce the problem.
And I might see some obvious “problem” in the file.

But, I just ran locale and see quite interesting output:

gerry@FBAcerLtp2:~> locale
LANG=en_US.UTF-8
...

Ok, so it is en_US.
Why do you call it “quite interesting”? :wink:

Actually I have to admit that I don’t remember why I asked for it.
It doesn’t really have any relevance to time zones anyway.

I’ve added the following to KDE Bugzilla entry 352509 - “kOrganizer 5.5.x sends iCal events with times converted to UTC”:

The same happens with KOrganizer version 5.3.0 (QtWebEngine):

The original libkcal file in ~/.local/share/korganizer contains:
DTSTART;TZID=Europe/Berlin:20170918T200000
DTEND;TZID=Europe/Berlin:20170918T213000

The iCal file sent via KMail2 contains:
DTSTART:20170918T180000Z
DTEND:20170918T193000Z

The KDE4 Plasma KOrganizer version 4.14 was exhibiting the same behaviour:

The original libkcal file in ~/.local/share/korganizer contains:
TZID:Europe/Berlin
TZNAME:CET
DTSTART;TZID=Europe/Berlin:20170629T200000
DTEND;TZID=Europe/Berlin:20170629T213000

The iCal file sent via KMail (KDE4) contains:
DTSTART:20170629T180000Z
DTEND:20170629T193000Z

Actually, this would be the more appropriate bug, I found it with a search (funny, must have used inappropriate search terms when I looked in the past) after following the link Wolfi provided.

https://bugs.kde.org/show_bug.cgi?id=373988

If you would be so kind as to add your two-cents there? Same for anyone else following this thread?

Added sixpence to the KDE Bug Report as comment #11.

FYI, the file dialog file filter problem should be fixed now (in 17.12.0):
https://cgit.kde.org/korganizer.git/commit/?id=da7d97d4a34f95fee0e8fffcb519b18a5da303d8

The reason was that the used Qt5 function actually expects a file name pattern, not a mime type, i.e. it would have only displayed files named “text/calendar”. (KDE’s file dialog apparently works with a mime type too though, and that’s likely the reason why this hasn’t been noticed before I suppose)

Thank you, Wolfi.

Well, I’m glad I found this, as I was having the same problem. What I did was to point akonadi to the URL. Then in Korganizer, I then invoked “add calendar” and selected akonadi. That added akonadi to the list of calendars, with subitems for each one defined to akonadi. (I only have the one, so I’m not absolutely certain it will do more than one, but it looks like it will.) Then, you can check or uncheck the display of each one as you choose - from directly within Korganizer.