is it possible to fix unreliable CPU thermal sensor error?

I get this from console…


dmesg | grep thermal
    5.927029] k10temp 0000:00:18.3: unreliable CPU thermal sensor; monitoring disabled

Hi
K10Temp Module
Some K10 processors have issues with their temperature sensor. From the kernel documentation (linux-<version>/Documentation/hwmon/k10temp):

On affected machines the module will report “unreliable CPU thermal sensor; monitoring disabled”, you can add the force=1 option


rmmod k10temp
modprobe k10temp force=1

If that resolves the issue then add to /etc/modprobe.d/99-local.conf


options k10temp force=1

thank you for the solution.

Hello,
I was trying to upgrade from SUSE 13.1 to 13.2
The process was rather smooth. But during the booting process I received the following:

(8.622011) k10temp 0000:00:18.3: unreliable CPU thermal sensor; monitoring disabled

"Welcome to emergency mode! After logging in, type “journalctl -xb” to view system logs, “systemctl reboot” to reboot
“systemctl default” to try again to boot into default mode.

The latter once brought me back. I could read the same from the journal though.

I used the recommendations like “options k10temp force=1” but “options” was not known.

Could someone give me the complete code to force into default mode?

Thanks in advance

Hi
Wow, old thread :wink:

Does the system boot if you remove the option?

If so, then let it boot and follow the commands above, does it now work?

Thanks for reply. I’m using Linux since 1996,. Well, there were many questions, problem, but never something like this.
Upon booting, the last screen I see are the options. When choosing 13.2 it seems the process runs in the background. The error message appears over the green, otherwise blank screen, in code format. This gives me three options, only the journal runs properly and shows me were the message came from.
When using “systemctl default” it starts over - no change.
when using (as SU) options this cnf message comes, do I do it without “options” “k10tmp force=1” error message something like unknown command. Using “mod- probe k10tmp force=1” result “fatal error”; “mod k10tmp” unknown.

So. the processor is pretty new an I was not aware, that this could perhaps be a coding problem.

I had 13.1 which was basically reliable. So this a a bad surprise.
Thanks for trying

I just entered as SU: rmmod k10temp
modprobe ktemp force=1

both instructions had been accepted.

Then

“systemctl default”

back to "Welcome to emergency mode!

Upon reboot - same response

Greetings

Hi
Why are you running systemctl default?

OK, lets take a step back :wink: you have the options set in grub?

If so, when you get to the grub screen press esc to stop the count down, select advanced and then press e to edit, arrow down and remove the option, then press F10 to boot.

I’m guessing you running a desktop or just console?

Now does the system come up and not to rescue mode?

If my assumptions are wrong, please provide some details from pressing the power button and up :wink: