Is it normal for Suse 11.0 to freeze

So far I’ve installed Suse 11.0 with KDE 4.0 and then a complete re-install with Suse Gnome . On both occasions while I was downloading updates and generally looking around the entire OS would freeze. Got to admit that the OS would freeze when I clicked on the top right corner of the screen.

Is this normal for a new OS or am I just lucky?

i’d say you are just lucky. OS11 should be able to run fine, however I found two serious problems with it (there are threads about them in the forum here):

  1. installing on reiserfs causes the system to freeze randomly

  2. the “official” nvidia drivers for O.S. are 173.14.05 which are really bad drivers and rushed by nvidia for Fedora9 causing LOTS of trouble. the newly released drivers (but not in the repos yet) are 173.14.09 are MUCH better and stable.

don’t know if either applies to you since there is no more information about your hardware/installation.



Thanks for getting back to me. I have a PC World own brand Advent laptop with no propriety drivers. Up till now this laptop has played nicely with all the distros that I have thrown at it. However as I am new to linux and most things are down to user error I can’t help feel that it is the user as much as the OS.


Post specs like ram, cpu speed, graphics card model.

If you haven’t disable/remove beagle many people have problems with this hound :wink:

Search here there’s a couple of threads, think just searching software for beagle may do it though.

Yes, I agree with removing Beagle. That thing is a resource hog like no other. Why they didn’t write the program in C++ or some native language I have no idea.

Also make sure you have enough swap space allocated. I made the mistake of allocating 256 MB of swap when I had 1.25 gb of physical RAM. It would just randomly freeze up. At first I thought it was because my computer was overheating, but it happened 5 seconds after I booted. Make sure you have at least 512 dedicated to swap space. Although I actually erred on the dangerous side and reduced it to 400 MB (It’s an 8 GB drive, can’t afford to lose 100 MB to swap i am not gonna use anyway).

My screen has been freezing too. I’m using KDE4

AMD 2800+
1 GB of RAM
ATI Radeon 9800 Pro

I put a full description here:

I’m in failsafe mode now, and it hasn’t frozen yet, if anyone has any ideas that’d be great. I’ve had my screen freeze about 9 times in the past hour.

I’ve been having what seems to be random freezes too. Haven’t been able to point it to any program or action i do. Have to use the laptop power boton to turn off/on again. Is there any log file or something i can read/use o try and find what might be wrong. OpenSUSE 10.3 32bit was totally stable btw.

Targa 826T/ MSI M635 notebook
Turion MT32
2GB DDR333
ATI X700 mobile
openSUSE 11 64bit, KDE 3.5


Going into failsafe mode at boot seemed to fix it for me. I’m waiting for someone to reply to the bug message I posted.

Could you guys post your swap partition sizes? I just wanted to confirm something.

Mine is 2GB, what was suggested by the installer and also the same size as i used in 10.3 if i remember correctly.
What exactly does “safe-mode” actually disable?

I’ve now uninstalled the fglrx driver from ATI and gone back to the opensource driver to see if i can see any difference.



I had the same problem - my fresh installation of opensuse 11.0 (network installation, with KDE4 and Gnome desktops) was freezing for no apparent reason after several minutes from boot (half an hour at most). I had no idea what caused this and no idea how to fix it and then I found this thread.

I can confirm that after switching off search services system no longer freezes.

Hope that helps.

My swap is 2 GB.

I’m about to try disabling the fglrx driver

It boots into a stripped down X server with a terminal in the top left corner.

I’ve never had the index search freeze my computer before. It just slowed it down. That’s really strange.

Changing the xorg.conf to an older one seems to have worked. I’ll post if the screen freezes again. But, there should be a solution to where I can use the latest drivers, and the screen not freeze.

I haven’t had any freezes after switching to the radeon opensource driver too. Seems to be it. Maybe the next fglrx driver will have better support for openSUSE 11. Doing --list pkg on the .run file only shows openSUSE up to 10.3.


Please disregard my previous post. Disabling indexing didn’t solve the problem (although freeze occurred much later). I left my laptop on over night and I found it frozen in the morning. sigh

So what’s the deal with xorg.conf? I have Intel i830 graphic card and I didn’t make any adjustments to xorg although I had some problem with X during initial boot. Don’t remember exactly what happened but it has something to do with the system being unable to save changes to xorg.conf - despite of this X started normally.

The screen freezing is REALLY annoying so any help solving this issue would be very appreciated.

whtvr, likely it’s a different problem. Both I and CJPB used the ATI driver (from the repository, I’m guessing) and it froze both our systems. Since you don’t have the driver I’d think it’s something else.

About the xorg.conf you can go here: /etx/X11/ and there should be a few files starting with xorg.conf the one without anything after it is the one being used. All the other ones are backups. I switched to one of those backups, and it seems to have fixed the problem for me.

I have also the freezing problem, see my post in the hardware section “suse 11.0 hangs” for more details.

I tried several nvidia drivers, all with the same result: system freeze after 5 till 10 minutes. The latest driver for nvidia 7500 series is working well on suse 10.3 (not on 11.0).


I stay so long by 10.3

My freezing problem is solved; see my post in the hardware section : Opensuse 11.0 hangs… - Page 4 - openSUSE Forums

I fear you are right: I have here 2 such laptop and suse 11 doesn’t survive “modprobe ndiswrapper”. In addition it installs a black screen: wrong xorg.conf, radeon or motherboard management? irqpoll doesn’t help.
On an gx600 the keyboard driver loads erratically. However, on Suse 10.3 everything works fine.