Is GRUB ver.2 compatible with OpenSUSE?

Hello everyone, I read that OpenSUSE uses the older Grub legacy and I was wondering if it is compatible with the bootloader of my Debian Squeeze installation? Will it be recognized by Grub v2?
I’ve used Ubuntu/Mint for 2 years and Debian for a year-n-half, but this is my first serious journey with the RPM family (checking out “the dark side” of the Linuxes >:)) so I am a newcomer and a semi-noob here (although I wont be for long! :P).

At the moment, I have a dual boot with Windows 7 on a separate 160GB harddrive; Debian on a 160GB partition on the 500GB drive, and another 160GB partition for OpenSUSE (I’m still thinking if I should also get Fedora, but OpenSUSE and Fedora both use RPM so I don’t exactly see much point–I prefer OpenSUSE really).

Thanks! I hope to be around these forums often and absorb the knowledge of the dark siders lol!

Grub2 will be the preferred default for opensuse 12.2 (probably out early September).

So…I can’t install OpenSUSE? :’(

Might have a look at this link: HowTo Multiboot Ubuntu from openSUSE using the GRUB bootloader, until openSUSE 12.2 comes out, its a manual task to mix openSUSE and grub legacy with Linux distros that use Grub 2. Once openSUSE 12.2 comes out, there will be less of a problem we hope.

Thank You,

I guess I’m not sure what you are trying to do.

If you want to install opensuse 12.1 in its own partition, and also keep ubuntu, then try:

Configure the installer to install grub (legacy grub) in the root partition. And set it to no set the partition active flag. I think that’s the Boot options button on the grub setup page of install.

After the install, when it reboots, it should then reboot into ubuntu. You can update the grub2 in ubuntu, so that it will add an option for booting opensuse. The chances are that just running the grub2 update script of ubuntu will already do this updating for you. Failing that, there are ways to do it manually.

And prevent it from writing a generic boot code in MBR … or it will be over with your Grub2. But if this happens - and it happens to most Ubuntu users - all you’ll have to do is to reinstall Grub2 under Debian, which is not a big deal.

You can have as many Linux distros as you like, no matter which boot manager they use by default, Legacy Grub, Grub2, Lilo … or even something else.

Yes, thanks for adding that.

set -e
exec grub-mkconfig -o /boot/grub/grub.cfg "$@"

openSUSE will be added to your Grub2 menu

  • Reboot, select openSUSE and complete the installation.

Notice that:

  • The pictures are for openSUSE 11.4, but it will be the same for 12.1.
  • In 12.2 the setup will install Grub2 in a partition bootsector but still write a generic boot code to MBR (AFAIK). They will never understand. I guess the only thing which could help in this matter would be a Novell/Canonical agreement that would invalidate the Novell/MS agreement. lol!
  • Fedora would be easier because it doesn’t write a generic boot code to MBR (tha’ts an opensusism). It might just replace your Grub2 with its own (which is not really a problem)

If you follow a tutorial that ends with the words “That’s all folks”… It might turn out to be the beginning of your problems. But if it’s a cartoon, just enjoy! lol!

@OP, this is not what you want - at least not what you asked. But as I read that you’re dual booting Windows and Debian on two separate HDDs, I’m kind of wondering where you installed Grub2 originally and which HDD is the first BIOS drive. If Windows is your first HDD and you installed Grub2 in its MBR, it’s not the best option for your Windows. In this case, openSUSE does a better job than Debian/Ubuntu. If you switched BIOS drive order and boot from your Debian disk (and not from Grub2 installed on your Windows disk), you’re right.