Is gnome-software completely broken?

Hello all,

I have two issues with gnome-software. The first and more serious issue, it doesn’t actually install software. Instead, it asks me to reboot and install, at which point I must go through two reboots and still nothing has been installed.

The second issue, it shows no software installed from any of the repositories (from the drop down menu). Each repo in the repo list shows “0” items installed, which if true, means I don’t have an OS running :slight_smile:

Is there a way to get it to actually work?

Trying to figure out what is going on with your system re: gnome install. You must be running some desktop to get software management to work.

From later parts of your text, it looks like you are using yast software management gui for your gnome install. Opening that, followed by a click on views → Patterns → Graphical Environments shows 3 GNOME package install options. Base, wayland, and x11. I assume you have none of these checked as being installed. Check to install base for a starter. Then click on accept at the bottom. Inform as to what happened.

If you are indicating you are going through above steps and there is no GNOME install options listed in the menu, I would suspect your repo list needs a review. If the options are listed and you check one gnome option (base, e.g.) and nothing installs after accepting selection, I would also suggest repo list check. Perhaps there could be another reason for install to not work that others may be aware of.

Report back with you progress.

tom kosvic

Hello tckosvic,

Gnome is running, as in gnome the desktop environment, as is the os, in spite of gnome-software telling me I have 0 packages installed from each repository :). My post is about the application “gnome-software”, gnome-software-41.4-150400.1.8.x86_64.

I tried to post a screen shot with my original message, but it doesn’t seem possible :frowning: … … it certainly would have made my meaning more obvious.

It’s a pretty gtk3 (gtk4?) stand-in for the yast software, but it integrates flatpak and perhaps some other junk. Anyway, it seems to be completely broken on Leap. I wouldn’t be surprised to learn that its just completely broken everywhere.

The only thing it does that I even halfway care about is download updates in the background, so that when I go to update with zypper, they are already cached and I don’t have to wait for the downloading part. But I don’t even think that is working correctly. Hard to tell just yet, as I’ve only had it installed for a few days

Isn’t there some package like Gnome-software-Appdata available?
I’m not using Gnome and Leap…

But you can find many results:
https://www.google.com/search?q=gnome+software+no+application+data+found

And your question is? This is technical support forum where people are asking to help in solving problems. If you just want to talk about it, better place would be chit chat. Besides title like in this thread looks too much like flame bait.

I am not a Gnome user, thus I did not answer here until now. I get the idea that many of those who answered above are also not Gnome users.

My impression is that the Gnome-software the OP is talking about is a piece of software existing within the Gnome desktop environment. Which means that he IS using Gnome. He is NOT asking how to install Gnome.

He uses Gnome-software (whatever that maybe) and expects apparently that it informs him different then he expects and he asks (from other Gnome software users in the first place) more information.

When my observations above are correct, I ask the OP to confirm this. And when he confirms, then please people that never used Gnome-software (or even Gnome), be netter cautious before posting here.

To the OP, it seems that there is some confusion here about what you are exactly using and doing. Please be aware that when the word “repository” or “repo” is used in these forums, most people will think about YaST Software Management and/or zypper.

My question: How might one get gnome-software to work correctly on leap 15.4?

I ran tumbleweed for a couple of days and had a similar problem, but was able to resolve it with three simple steps:

  1. rm -r ~/.cache/gnome-software
  2. appstreamcli refresh --force
  3. pkcon refresh force -c -1

Of course, I have tried the same approach on leap, but without success. I am hoping that someone knows some little trick, hack, configuration option that will get the app to work correctly.

Thanks Henk!

Definitely a little confusion … I really WISH I could have uploaded a screen shot, which would have made the issue VERY obvious. The word “repository”, often shortened to “repo”, seems to be ubiquitous around package management in general. Gnome-software looks at the same repositories as Yast and zypper, but also integrates with flatpak and with an open firmware repository, of which I know NOTHING about. It may be possible to point at other non-rpm schemes such as “snap” with it, but I don’t actually know. As this integration if fairly new and rather ambitious, the growing pains are still apparent.

Just a few remarks.

You can upload images to http://paste.opensuse.org. Top-right there is the button Image. Post the URL to the resulting page (not to the picture) in your post.

This is openSUSE. And openSUSE has it’s native software management implemented with YaST > Software / zypper. That is what everybody here is used to. All other things are more or less “not invented here” :wink:

1 Like

BIG THANKS for the image tip!

Hello, thanks and YES:

libzypp-plugin-appdata-1.0.1+git.20180426-150400.16.5.noarch

That is already installed. I just confirmed that it DOES actually install software (I can’t believe I had not tested this part yet). I installed aisleriot-3.22.5-bp154.1.92.x86_64. It seems to be updates that are problematic, and the listing showing zero applications installed is really and aesthetic issue as much as anything. I hope to know more as updates become available.

Magic, my computer runs without anything installed :slight_smile:

https://paste.opensuse.org/32033009

https://paste.opensuse.org/32033009
https://paste.opensuse.org/32033009

I cannot reproduce it. When I install new application, this application is installed without reboot. For updates gnome-software by design invokes packagekit offline update. You did not even describe what you did, so any answer will be wild guess.

at which point I must go through two reboots and still nothing has been installed.

It is possible that installing updates fails due to issues with dependencies, it happens sometimes. You provided zero information that would allow anyone to troubleshoot it. But given recent problems with some patches you may have hit this issue.

The second issue, it shows no software installed from any of the repositories (from the drop down menu).

https://bugzilla.opensuse.org/show_bug.cgi?id=1202585

@oxWrongAgain, I misinterpreted your initial query and thought you were trying to install gnome. I see a package called gnome-software aka gnome software store. I do not have it installed. I will install and try it but I am doing some stuff in mate desktop and can’t do a re-login for a few hours. If someone gives you an answer, I will not do it.

KDE has it’s own software manager called discover. That process barely ever works for anyone. Perhaps gnome-software has similar issues.

tom kosvic

Hello and thanks for taking the time to reply!

As you aptly point out, “You did not even describe what you did …”. Oooof! I definitely need to be more thorough and thoughtful the next time I post a question.

Very short version of what I did: Opened gnome-software, clicked on the updates tab, where it displayed a message indicating that an OS Update was available and would require a reboot. I clicked the button which read “Install and reboot”, at which point my box rebooted twice, but no software was actually updated.

“It is possible that installing updates fails due to issues with dependencies” … **I think THIS IS IT!
** Yesterday, or maybe even the day before, an update for “python3-py” was posted in the SLES update repo. However, that update depended upon “python3-iniconfig”, which did not post to the repo until yesterday late morning or early afternoon. It appears that is was PURE BAD LUCK that I was testing the update feature of gnome-software for the first time during a window with an unsolvable dependency in the repo. I really do love " /var/log/zypp/history" :slight_smile: ] Of course, gnome-software should handle the situation more gracefully than double reboot, but I don’t think that it is as broken as it initially appeared to be!

The link to bugzilla you provided directly addresses the second part of my post. Thanks! I might even build an rpm with the patch … or I might forget it as I really do consider it an aesthetic annoyance more than an actual problem.

So hopefully, I can post after the next set of updates become available that gnome-software actually mostly works, unless it finds an unsolvable dependency.

Now back to testing tracker3-sparql, which is giving me malformed uri’s when filenames contain apostrophes and/or ampersands … the fun never really stops … :slight_smile:

Cheers!

Thanks tom,

I think I now know what the problem “is/was” … see my reply to @**arvidjaar

“… **process barely ever works for anyone …” Too funny!

On one hand, solutions like “gnome-software” and “discover” are totally unneeded as any decent distribution is going to have a robust package management solution (such as zypper,dnf,apt,etc.) in place. Still, I do think it is a step forward to have an elegant and attractive front-end to handling “Software” in the broadest sense. Gnome’s solution allows the end user to browse flatpaks as well as packages in the configured repos. I don’t know if it integrates with snap as well.

Be well!

While it may allow the end user to see repos with system software, (s)he can still not do much with it.

Hello again,

I don’t understand what you mean.

This morning I installed “aisleriot” from gnome-software, which is in the main repository. Just now I installed a flatpak of “calibre”. In both cases, at the end of the download, I was prompted to authenticate as root in a pop up window before the installation would complete. It would definitely be slicker (cooler, more hip, whatever …) if it would provide an option install for the user only. I am fairly certain that this is an option from the flatpak cli.

For packages like “aisleriot” and “okular”, which I am looking at now, I can choose to install either the flatpak or from the repos.

One thing I did notice a few weeks ago when I was playing with tumbleweed is that it doesn’t do a complete uninstall, but I guess that is to be expected for obvious reasons. It executes the equivalents of “zypper rm PKGNAME” or “flatpak uninstall PKGNAME”, where as I would generally use “zypper rm -u PKGNAME” or “flatpak uninstall PKGNAME && flatpak uninstall --uneeded”. Sometimes, “zypper rm -u” will select far more than expected, so …

Cheers!

In Linux you must be root to install system wide software. Unlike other less secure OS cough cough Windows… So do you want something pretty or secure???

Hello @gogalthorp,

To be perfectly honest, “PRETTY”, and preferably easy and intuitive to use. I am perfectly comfortable with the cli and genuinely don’t mind writing and/or hacking code, but when push comes to shove, I want the UI to be attractive and EASY! Deb based distros authenticate much like windoZe … the installer’s password is effectively the root password unless you change it.

I think folk in general have been more than a little overzealous about security (including ME!, perhaps especially ME!). With the exceptions of “/” (root) and “/boot/efi”, all my file systems are luks2 encrypted. I mount “/home” with the “discard” option so that deleted files are immediately deleted. I’d probably alias srm to rm for my non solid state devices if it weren’t so slow. Like everyone else, I run a firewall on my computer and another at the router. My passwords are insanely obtuse. But if I am honest , I have to concede that my computer hosts information that would be of very little interest to anyone other than myself. I certainly want to guard against having my box hijacked for other purposes, but how security conscious do we really need to be? I am not a BANK or a POWER PROVIDER or even a small business to pay a ransom.

Just for giggles, I recently installed windoZe 11 in a vm and I have to admit I was fairly impressed. Definitely a step up in many ways from any existing linux distro. In other ways … well, it is still windoZe :). If I want to search my video collection based on embedded metadata, NO PROBLEM! Windows indexing takes care of it … I write my search terms into the windows explorer search … and bang! … MAGIC. Oh yeah, tracker does that, and it actually does so fairly well. Sadly, real tracker nautilus integration has either been broken or removed. The closest thing to user friendly video search on linux (default installation) right now is "tracker search -v SEARCH_TERM [SEARC_TERM … ]. There is an implicit “AND” operator. An “OR” operator is optional, but that feature is currently broken. Recoll actually does a decent job with mp4 video, but has no ability to cope with mkv (At some point over the next few months, I am going to write an mkv data sucker for recoll. It actually looks fairly easy). And the search interface is decently designed and attractive. I have read that it will integrate nicely with dolphin, but I have not tested this yet, and may never get around to it as I don’t use dolphin. On opensuse, you probably have to build from source, which proved to be ridiculously easy on Leap 15.4.

As much as I love to bash Microsoft, Linux is not nearly as compelling today as it was a decade ago.

Just food for thought!

cheers