is down?

i just cant get into repos…my internet is working anyone has the same problem ?

Looks that way . >:(

hope it comes back fast…i want to try kde 4.4

I think so. Until I saw this post I was freaking out because I just installed OpenSuse today and I can’t get updates or install my Nvidia driver haha. I was like WHAT WENT WRONG!!!

That could be what the problem is, you and countless others. Switch to a mirror
openSUSE Download Mirrors - 11.2

finrodfelegund wrote:
> i just cant get into repos…my internet is working anyone has the same
> problem ?

see the thread “install software slow” in this forum…

and, when you get there ask if anyone has logged a bug…


It seems that they are down. I can’t access them with zypper and a browser.

i am trying to find any releated articles about changing the mirror…but i am not sure how that can be done…i am too new to opensuse…

Repository Management - openSUSE Forums

delete one Eg; Updates
add one back as local to you as you can find.

Here’s a useful site that can check another site:

It’s just you.

I think this would be ok for you

Online Archive :: RoEduNet

thanks man fot the help !! u made another happy n00b :slight_smile:

It must have just ended,

The point is this site allows you to check it yourself first before asking around.

On this OS11.2, KDE 4.3.1 both Yast and zypper fail to connect to repos, all of them. When I copy paste failed repos urls into a browser server seem to respond just fine.

Update on the OpenSuse notebook on the same network has no
problems whatsoever.

Something must be wrong with my system. Why can’t zypper connect to anything?


So, what could cause zypper to fail to connect to the internet? Repos are working fine, it’s something on my end.

This week I “termed” update applet a few times from system monitor when it failed, usually it allowed Yast to update manually, not anymore. Has it left some kind of “lock” somewhere?

This is what you can do about this matter:

Start Yast - Repo manager
Remove all repos
Accept and exit, start repo manager again and add repos from scratch. Don’t be scared, the essential ones are preconfigured and added like this:

click Add - Community repos, select these:

Import the keys if/when asked for. The repos will now be rebuilt. Accept and exit.

Now start the software installer and all should be working.

Stan Ice wrote:
> Bump.
> So, what could cause zypper to fail to connect to the internet? Repos
> are working fine, it’s something on my end.

probably you did it when you terminated a running zypper/yast…

you can try the following, it might work for you, it has worked for
others who killed their zypper/YaST by terminating YaST/Zypper or the
Online Updater before they are finished–that is almost never the best

open a terminal, then type the first line below and press enter, type
in your root password (you will not see what you type) and hit enter
again…then WAIT until all activity has stopped and you are returned
to the command prompt, and then type the second, wait, repeat

su -

rpmdb --rebuilddb

zypper ref

zypper up

NOTE: some of those steps may take a LONG time…so, do NOT being the
process unless you have (say) a full hour where you can just let the
machine ‘think’ and fetch repairing code…start the rpmdb rebuild
and do something else (NOT on the computer)…like watch TV or go
outside and play in the street (-: in traffic ;=) then check the
machine in (say) half an hour and if it is finished, then do the next
step…if you get an error -=STOP=- do not do the next step, instead
copy/paste the error back to here (and cross your fingers that someone
knows how to help–i doubt i will)…

After that try YaST or the Online Updater again…

or, many turn off the Online Updater since if it happens to be running
when you want to use YaST, you can’t…or, if YaST is in process of
managing software then the Online Updater, can’t (they both use the
same backend, zypper)…

good luck, if it works for you know that the above four step solution
already exist is in these fora many times, and can be found, not by
bumping, but by searching…


hello Stan! please follow the advice given by Knurpht as his might fix
it faster and easier!!


Knurpht’s method didn’t work - Yast failed to download repositories even from the scratch.

Will try rebuilding from terminal when I have more time.

Waiting for a failed update applet to terminate itself seemed hopeless. Several times I noticed it hours after the failure when I tried to install some programs with Yast and it gave out an error with update applet PID.

Oh, just got “zypper ref” reporting:

Failed to download /repodata/repomd.xml from Index of /suse/11.2
Abort, retry, ignore? [a/r/i/?] (a):

I’ll go with abort for now.

Should I resort to “repair existing system” with OpenSuse install DVD, or are there some less dramatic options still left?

I suspect it’s the internet connection problem, not zypper or yast or repository configuration. Can something else cause “failed to download” error?

Internet itself is stil accesible for browsers, torrents and usenet programs.