Is any other gnome user having this problem?

I think I found my first openSUSE 11.0 bug! :stuck_out_tongue:

I made a report here:

Here is what happens, right click on desktop and change desktop back ground, drag a desktop picture to the back ground to change, try it a few times if not once and nautilus crashes and the desktop reloads.

Can someone confirm this?

It had never occurred to me to do it that way, by dragging a picture to the desktop. I always just click on the one I want within the backgrounds tab and it just changes. I have tried dragging the picture out to the desktop several times, after I had done it maybe more than 7 or 8 times I noticed the icons on my desktop briefly disappear then re-appear, but did not have any Nautilus crashes as such.
Regards Peter.
Running RC 2 64 bit, it has updated itself to Gold.

Hmm. It did the same for me. First time I drag a background to the desktop it freezes then I get a crash report. Nautilus opens. After that it works as expected.

I have had this before with the beta’s. Running GM version of openSUSE 11 now and it’s all good. No crash and I’ve tried the action 10/12 times. so could be it’s fixed?

Here r the crash details:

Distribution: openSUSE 11.0 (i586)
Gnome Release: 2.22.1 2008-06-07 (SUSE)
BugBuddy Version: 2.22.0

System: Linux #1 SMP 2008-06-07 01:55:22 +0200 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10400090
Selinux: No
Accessibility: Disabled
GTK+ Theme: Gilouche
Icon Theme: Gilouche

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0

----------- .xsession-errors ---------------------
Nautilus-Share-Message: spawn arg “net”
Nautilus-Share-Message: spawn arg “usershare”
Nautilus-Share-Message: spawn arg “info”
Nautilus-Share-Message: end of spawn args; SPAWNING
Nautilus-Share-Message: returned from spawn: SUCCESS:
Nautilus-Share-Message: exit code 255
Nautilus-Share-Message: ------------------------------------------
Nautilus-Share-Message: Called “net usershare info” but it failed: ‘net usershare’ returned error 255: net usershare: usershares are currently disabled
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2e000c2 (Software L)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option “menuitemstyle” is not supported and will be ignored.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option “listviewitemstyle” is not supported and will be ignored.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option “progressbarstyle” is not supported and will be ignored.

can someone help me make a back trace for this crash as required by the bug report…

They have pointed you sort of in the correct direction.

They’ve suggested installing nautilus-debuginfo will give them enough info in bug buddy.

Or the other way is as wiki page install gdb

pidof nautilus
attach 12345

Where 12345 is the pidof nautilus
then crash it
type at the gdb cli

thread apply all bt

Post everything below gdb command.

Thank you for the reply FeatherMonkey, but I am still unable to do it, the thing is that nautilus does crash but I can’t reproduce the bug while doing those steps cause I am uname to perform the action required to crash it.

exactly, do u know how to produce a back trace or something like that?

What do you mean the easiest is to add the debug pkg and replicate then just paste the bug buddy output.

Really not sure what you mean by uname, but guessing you’re saying you can’t replicate it, or can’t do it.

whereis nautilus
gdb /path/to/nautilus
crash it
then the gdb bt command see if that helps.

Alright then but I can’t find a specific nautilus debug package, which repo do I need for it, thanks

Valid point hehe if you’ve got a debug repo in the repo list try there. Otherwise I’ve got no idea, webpin is not helping, go back and perhaps ask or you’ll have to persist with the gdb way.

yeah thats the problem can’t find the debug repo, I guess I will try to learn that method or wait for a debug repo :slight_smile:

Alright I seem to have extracted something from the crash, can someone look here and tell me if this is what they were looking for, thanks