is alsa there or not?

my sound broke when i updated my suse11.0 box. (or possibly when i installed skype)
i was reading the help for broken sound…
SDB:AudioTroubleshooting - openSUSE

i found alsa was installed with…
rpm -q alsa alsa-utils alsa-firmware

spekertest did not get sound… nor did the yast config stuff…

so i arrived at alsaconf… but it was not installed when i tried to run it. ok… so i try

penguin:/home/andrew # zypper install alsa
Reading installed packages…
‘alsa’ is already installed.
Nothing to do.

fine… maybe updating it will get it onboard…

penguin:/home/andrew # zypper update alsa
Reading installed packages…
Package ‘alsa’ is not installed.
Nothing to do.

um… now i’m confused… i’ll buy beer for the first iguana who can educate me


Did you tried to install the latest version of alsa. You can check in yast. i faced same issue but in 11.1, by putting this line did the job for me in /etc/modprobe.d/sound.

options snd-hda-intel enable_msi=1

Tried out this thread, maybe can help you.
Sound issue – Intel Hda - openSUSE Forums

Alsa IS there.

Its possible you do not have your repositories setup properly. What is the output of:
zypper lr -d

To help with your sound problem, I usually need more information. If using openSUSE-11.0, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and copy and paste the following :

wget -O && bash

that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation (as opposed to a guess).

wow thanks for your help…

the script gave this url…

then the package manager commands…
andrew@penguin:~> rpm -qa | grep alsa

rpm -qa | grep pulse
this returned nothing as i’ve uninstalled that stuff. on advice from another forum. and i seem to recall linux outlaws saying pulse audio was bothersome too?

andrew@penguin:~> rpm -q libasound2

andrew@penguin:~> uname -a
Linux penguin #1 SMP 2009-06-01 09:57:12 +0200 i686 athlon i386 GNU/Linux

(hmmm… i feel naked now)

andrew@penguin:~> cat /etc/modprobe.d/sound
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1

the output from the zypper comand will not fit in here as it about 150 char wide!! but i think i have to look at what repos i have… i got somthing from the pacman repo a while ago, and then read stuff from there was often buggy… so i’ve removed that one (which probably upsets the packages it was suporting)…


in my afternoon noodlings i found an alsa tools package… so i installed that and there was alsaconf… i ran it, pressed return the required amount of times… heard my speakers click and scratch once at the end… but still no sound.


actually, it will. Paste it in the box, select it, and press the " # " icon on the top of the edit box. That will put it as code, and keep it in a box where one can scroll back and forth. The box will look like this.

This is an example of a box where one has created very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very very long text.

From the script I note this:

!!Amixer output

!!-------Mixer controls for card 0 [Live]

ALSA lib conf.c:3009:(snd_config_update_r) Cannot access file /etc/alsa-pulse.conf
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
amixer: Control device hw:0 open error: No such file or directory
ALSA lib conf.c:3009:(snd_config_update_r) Cannot access file /etc/alsa-pulse.conf
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
amixer: Mixer attach hw:0 error: No such file or directory

thats definitely not good! Did you run that BEFORE or after you ran alsaconf ? If you ran it before (running alsaconf) then please run it again and provide the URL.

Also, please can you reboot your PC, and immediately after booting, connect to the Internet, and then run this dmesg/curl command to post your dmesg to the web:

dmesg > dmesg.txt && curl -F file=@dmesg.txt

That will give you a URL. Post the URL address here. Just the URL.

alsaconf was run before i ran the wget… script

the url i get from the dmesg/curl is…
dmesg.txt - (beta)

i can’t see any reference to alsa there at all?? though the game port seems to be reffed?

Typically one will see a reference to “alsa” or “snd” or “hda”. I see none.

Can you try to force a reinstall of alsa, alsa-utils, alsa-firmware, alsa-oss, alsa-plugins, alsa-tools-gui ? Then reboot and test. If that does not work, then it may be easiest to just install 1.0.20 of alsa, and I will give you the appropriate zypper commands to do that.

well the badness is gone…
i ran;

zypper install -f alsa alsa-utils alsa-blah balh balh… etc…

here i got an error that something was using the zyper library or something…

so i reboot and try again… when it updated the repo list it popped an error window complaining it could not complete that but i ignored it as **** was still scrolling by in the console… i wait… a cup of coffee even… it finishes…

i try to run alsaconf… command not found… so i go to yast and try to configure the sound card there (old sound blaster live). all seems to work fine now…

thanks for all the help…

i’m curious as to why alsaconf did not arrive with the alsa-utils or alsa-tool-gui packages?

It reads like you were having a bad day. You probably forgot to run it with root permissions. alsaconf is part of the package alsa-utils. I found that out via the below method:

oldcpu@hal1000:~> su -c 'which alsaconf'
oldcpu@hal1000:~> rpm -qf /usr/sbin/alsaconf

Glad to read your sound is now working.

~scratches head~

yes… maybe i did forget to run it without a sudo…

i can’t recall… it was pretty early in the morning here then… so anything could have happened…

anyway thanks for you help and ideas… i’ve learned quite a bit from this experience.