IPv6: privacy extensions settings ignored

My ISP provides IPv6 connectivity and everything works fine except for one thing: I can’t enable privacy extensions for IPv6 on one single machine, the one with OS Leap 42.1 (the other with OpenSuse 13.2 is not affected).

As far as I can see, ipv6-privacy is enabled both in Networkmanager and in the kernel:

# cat /proc/sys/net/ipv6/conf/{all,default,eth0}/use_tempaddr

# nmcli connection show "Wired connection 1" | grep -i privacy
ipv6.ip6-privacy:                       2 (enabled, prefer temporary IP)

This machine gets its IPv6 address via radvd.

What did I miss?

There’s an open bug report on this: bug 966999

It seems to only be a problem with NetworkManager. I have configured my systems to use “wicked” and am not having problems. I do reconfigure my laptop for NetworkManager when I travel. But most of the time, I don’t see any IPv6 addresses when traveling.

Thanks. It makes sense, the other PC, the OSuse 13.2 with privacy extensions working, is configured to use wickedd.