iPod touch 2g software

Dears, is there any software available on linux to manage iPod touch 2g?

i can use iTunes with VirtualBox but i want to do in in SuSE itself!


I use iTunes in Virtualbox to manage my iPods (including a touch 2g), because I found that most of the apps don’t quite do it right. THe app that I would like to get my hands on is gtkpod-acc (the normal gtkpod doesn’t support AAC files), but unfortunately there isn’t one for Opensuse, and my attempts at building one have failed.

You are effectively left with:

Banshee-1 for Gnome
Amarok 2 for KDE
Songbird (nice but slow)

Ofcourse you can install either Banshee or Amarok onto opposing (?) desktop, the OpenSuse installer will install the required depenancies. Amarok is very nice, but now that I’ve got Banshee to work I use that.

My approach is to have one “database” of music which iTunes in Virtualbox and Banshee look at. So I play music on my PC with Banshee, but sync my iPod with iTunes.

The latest Banshee-1 (1.4.1 I think) is meant to have been syncing abilities but I’ve not tried it yet.


Amarok 2 doesn’t support iPods yet. Go for the 1.4 version, or Songbird.
There is another nice application for managing iPods called Floola. It’s available from the Packman repo - and If you are using KDE4 I recommend you this application.

do u think it has support for ipod touch 2nd generation?

I don’t know visit the project site. My iPod is a 2GB Nano.

You can SSH onto your ipod using a package called ipod-convenience (im not sure if your ipod has to be jail-broken or not) it just requires the sshfs package to be installed :

ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/cyberorg/openSUSE_11.1/noarch/ipod-convenience-0.9-2.3.noarch.rpm 11.1
ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/cyberorg/openSUSE_11.0/noarch/ipod-convenience-0.9-1.1.noarch.rpm 11.0

and gtkpod should work fine :wink:

hope i helped :slight_smile:

Thanks for your response. where can i get ipod-convenience? it is not in openSUSE repos.

Not true. If I plug in my son’s iPod, it shows up in Amarok2 and I can do all operations required to manage the music collection on the iPod. Out of the box.

Though I had some trouble at a friend, where it did not work in Amarok 1.4.* nor 2.*. We found out that the front USB on his machine was still USB 1. Connecting it to an USB 2 port solved all.

Would you mind telling us if the iPod is an iPod Touch 2 gen? or simply a first generation?

Take a look to the date of my post: 02-Feb-2009.
In February this statement was true.