ipod mounts in gnome but not kde

My kids each have an ipod touch. Occasionally I connect them to my laptop and use dolphin to pull the pictures off them.

I’ve noticed recently that the ipods don’t automount in kde. I know that they were mounting under suse 11.3 (kde 4.5); I can’t remember whether they ever mounted under 11.4 (kde 4.6.3). Last night I needed to back up the ipods, and I found that I could do that if I booted into gnome (they mounted right up as volumes in gnome), so the issue seems to to be kde-specific.

Suggestions on how to proceed with investigating the cause?

Is it only the iPod that has this problem? Plug it in and show the output of

fdisk -l



Here ya go. The ipod doesn’t show up in the mount query.

fdisk -l 

Disk /dev/sda: 640.1 GB, 640135028736 bytes 
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors 
Units = sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disk identifier: 0x000b7777 

   Device Boot      Start         End      Blocks   Id  System 
/dev/sda1            2048    31457279    15727616    7  HPFS/NTFS/exFAT 
/dev/sda2   *    31457280  1250263039   609402880    f  W95 Ext'd (LBA) 
/dev/sda5        31459328    35680255     2110464   82  Linux swap / Solaris 
/dev/sda6        35682304    88117247    26217472   83  Linux 
/dev/sda7        88119296  1183123455   547502080   83  Linux 
/dev/sda8      1183125504  1250226175    33550336    c  W95 FAT32 (LBA) 
devtmpfs on /dev type devtmpfs (rw,relatime,size=1666792k,nr_inodes=416698,mode=755) 
tmpfs on /dev/shm type tmpfs (rw,relatime) 
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000) 
/dev/sda6 on / type ext4 (rw,relatime,user_xattr,acl,commit=600,barrier=1,data=ordered) 
proc on /proc type proc (rw,relatime) 
sysfs on /sys type sysfs (rw,relatime) 
debugfs on /sys/kernel/debug type debugfs (rw,relatime) 
/dev/sda7 on /home type ext4 (rw,relatime,user_xattr,acl,commit=600,barrier=1,data=ordered) 
/dev/sda8 on /media/fat32 type vfat (rw,nosuid,nodev,noexec,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro) 
securityfs on /sys/kernel/security type securityfs (rw,relatime) 
none on /proc/fs/vmblock/mountPoint type vmblock (rw,relatime) 
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime) 
gvfs-fuse-daemon on /home/john/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=100) 

Just for fun, I booted in to gnome and plugged the ipod in. It mounted up on the desktop automatically. I ran the above commands and got the same results. Seems to be a kde thing.

Is it detected in Amarok?

No. Not detected by Amarok.

Check to see if you have libgpod installed. In the terminal enter

zypper se -i libgpod

Yes, libgpod is installled:

zypper se -i libgpod
Repository 'Local RPMs' is out-of-date. You can run 'zypper refresh' as root to update it.
Loading repository data...
Reading installed packages...

S | Name          | Summary                                            | Type   
i | libgpod-devel | Development files for libgpod                      | package
i | libgpod-tools | Tools for libgpod                                  | package
i | libgpod4      | Library to Manipulate Songs and Playlists Stored-> | package

I don’t know. If it’s formatted in Apple’s HFS file system, you might have better luck with FAT32. iTunes on Windows should do this for you. I can’t think of anything else that might help.

Thanks. As I said, it is mounting up fine under gnome on the same laptop. My feeling is that this is a kde settings thing, like it’s getting directed to the wrong app or something. I guess I could try a live CD and see if it works there…

OK. It seems that this problem goes away when I set up a new user. In other words, when I log in as a new user, I can plug in the ipod and the notifier tells me that I have plugged in a camera. This is good! What that implies is that there is something messed up in my ~/.kde4 folder. I really don’t want to delete the whole thing. Can someone suggest things that I can try renaming?

Just an update. It turns out that entering

dolphin camera:/

will bring up the ipods in dolphin. This is good, but I really shouldn’t have to go to a terminal… I guess the problem is situated somewhere in the notification app.

I’m thinking of purchasing a Tablet, and so to help me get a better flavour as to the sort of interface one can encounter in a Tablet (and applications) my wife has agreed to lend me her iPod Touch 3G when ever she is not at work.

So in preparation I installed gtkpod, libgpod, libimobiledevice, liblist, usbmuxd and ifuse on my 64-bit openSUSE-11.3 which is running KDE-4.4.4. I plugged in the iPod and did not see anything when I typed “fdisk -l” with root permissions.

Still undeterred, I created a mount point under /home/oldcpu/ipod , and as a regular user I typed:

ifuse /home/oldcpu/ipod

and her iPod Touch 3G mounted. I see could many of the iPod’s files under dolphin. Still I found the file structure confusing, so I ran ‘gtkpod’ which launched a GUI. I had to enter the model # from my wife’s iPod 3G as part of the gtkpod setup.

After that, it appears to sync.

I took a .mp4 video file, and also a .m4v video file that I created with handbrake (using the iPod setting in handbrake) and loaded them on to the iPod Touch 3G via gtkpod. The videos play fine in the iPod using the very basic video player application that comes with the iPod.

I also tried some mp4 files (on the iPod) that I created with h264enc and they also played, but unfortunately they had a video/audio desync introduced that I did not have in handbrake.

I did find that handbrake would not accept all video formats for conversion, and in one case I had to convert a video file with avidemux to a format that handbrake would accept (in essence I kept the audio/video but had avidemux change the wrapper information). It appears handbrake is more sensitive to what is in the video wrapper than many other applications.

While I was able to mount the iPod as a regular user with ‘ifuse’ I found that to unmount I needed to use root permissions.

I suspect that if I just run ‘gtkpod’ (with iPod plugged in) without mounting with ‘ifuse’ it may still work … I need to test that.

I should note that this iPod is NOT jailbroken. I’ve read thou, that for the iPad and iPod Touch 4G they need to jail broken for this to work. Fortunately for the 3G it does not need to be Jailbroken.

That should have read openSUSE-11.3.