iPod mounting problems

Just had to replace the hard drive on my wife’s iPod Classic 6th Generation. Now I cannot mount the device. It works fine on Windows and Mac computers. I have tried formating it on both Windows and Mac, I’ve done restores through Itunes on both. Here is what I get in my /var/log/messages

kernel: [84412.470389] scsi10 : usb-storage 1-5.3:1.0
kernel: [84413.477317] scsi 10:0:0:0: Direct-Access     Apple    iPod             1.62 PQ: 0 ANSI: 0
kernel: [84413.477445] sd 10:0:0:0: Attached scsi generic sg7 type 0
kernel: [84413.500917] sd 10:0:0:0: [sdf] Spinning up disk....ready
kernel: [84417.622891] sd 10:0:0:0: [sdf] 19488471 4096-byte logical blocks: (79.8 GB/74.3 GiB)
kernel: [84417.623387] sd 10:0:0:0: [sdf] Write Protect is off
kernel: [84417.623389] sd 10:0:0:0: [sdf] Mode Sense: 68 00 00 08
kernel: [84417.623390] sd 10:0:0:0: [sdf] Assuming drive cache: write through
kernel: [84417.624518] sd 10:0:0:0: [sdf] 19488471 4096-byte logical blocks: (79.8 GB/74.3 GiB)
kernel: [84417.625077] sd 10:0:0:0: [sdf] Assuming drive cache: write through
kernel: [84417.625080]  sdf: sdf1
kernel: [84417.644514] sd 10:0:0:0: [sdf] 19488471 4096-byte logical blocks: (79.8 GB/74.3 GiB)
kernel: [84417.645073] sd 10:0:0:0: [sdf] Assuming drive cache: write through
kernel: [84417.645076] sd 10:0:0:0: [sdf] Attached SCSI removable disk
kernel: [84432.721342] sd 10:0:0:0: [sdf] Unhandled sense code
kernel: [84432.721345] sd 10:0:0:0: [sdf] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
kernel: [84432.721347] sd 10:0:0:0: [sdf] Sense Key : Medium Error [current] 
kernel: [84432.721350] Info fld=0x0
kernel: [84432.721351] sd 10:0:0:0: [sdf] Add. Sense: Unrecovered read error
kernel: [84432.721354] sd 10:0:0:0: [sdf] CDB: Read(10): 28 00 01 29 5e c0 00 00 01 00
kernel: [84432.721358] end_request: I/O error, dev sdf, sector 155907584
kernel: [84432.721361] Buffer I/O error on device sdf, logical block 19488448
kernel: [84442.732816] sd 10:0:0:0: [sdf] Unhandled sense code
kernel: [84442.732819] sd 10:0:0:0: [sdf] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
kernel: [84442.732822] sd 10:0:0:0: [sdf] Sense Key : Medium Error [current] 
kernel: [84442.732825] Info fld=0x0
kernel: [84442.732826] sd 10:0:0:0: [sdf] Add. Sense: Unrecovered read error
kernel: [84442.732828] sd 10:0:0:0: [sdf] CDB: Read(10): 28 00 01 29 5e c0 00 00 01 00
kernel: [84442.732833] end_request: I/O error, dev sdf, sector 155907584
kernel: [84442.732835] Buffer I/O error on device sdf, logical block 19488448
udevd[521]: worker [12824] unexpectedly returned with status 0x0100
udevd[521]: worker [12824] failed while handling '/devices/pci0000:00/0000:00:12.2/usb1/1-5/1-5.3/1-5.3:1.0/host10/target10:0:0/10:0:0:0/block/sdf'

Some googling led me to this, ipod mini - usb on a SuSE system - Page 3. So I compiled a kernel and disabled CONFIG_EFI_PARTITION and got the same results.

Kernel - 2.6.34.7-0.3-desktop
openSUSE 11.3
KDE - 4.5.2

Help!

Do you have any tools to handle the ipod. I have a calssic nad I use gtkpod to upload and delete music off min, I dont know if you have to have some thing like that installed for it to see the ipod device, may be it has a lib that handles that.gtkpod iPod Manager Oh and this is in you repos.

From reading your log I can’t see why it’s giving you a Buffer I/O error on device sdf, logical block 19488448. This may sound weird is it a USB 2.0 and your using a USB 1.0 plug?

These are the only things I can think of right now.

Thanks for the reply. I should have mentioned that I have previously been able to sync this ipod. I have tried gtkpod, Amarok, Clementine, nothing works because it won’t mount. I haven’t synced in a couple of months, so it was a few kernel versions ago and KDE 4.3 (I believe). I can’t believe that’s it the new hard drive since it works on both Windows and Mac machines.