Ipod and Amarok 1.4 & 2 on openSUSE 11.4

I am trying to get my ipod to work on 11.4.

The ipod is classic 6th gen.

It worked very fine on 11.1, using Amarok 1.4, both to manage my local music and the ipod.

Now I got two issues:

#1 Amarok 2: copy to ipod

Amarok 2 (I leave the rant to another sub-forum!) somewhat works for giving me a local collection scan, but as for copying anything on the ipod, it is clueless.

I get “Apple IPOD” on the left pane on top of local collection. When I try to copy something to it, it gives me a weird dialog box asking how to copy it, what to put in the filename and what subfolder. It also proposes to dump that into /media/IPOD, which is just… wrong, because the correct path seems to be /media/IPOD/something-control/music/f##

Yeah, I can set the music folder in the config of it, but it still give me that silly stuff. Anyway it fails to copy, and when I get it to copy, the ipod won’t list it.

Tried clementine: works very well for the local music scan. But for the ipod, I get the exact same result as with Amarok 2: dumps the files out there…

#2 Amarok 1.4

It works fine to see the content of the ipod, but there is a problem. I am unable to scan my mp3 folder and make a collection with it! Once I select one folder (with just 8 mp3s, to test it), it says “Please be patient…” The progress bar shows nothing. Waited an hour. No result. Flushed the folder ~/.kde/share/apps/amarok, tried again, no difference.

Anyone here got a local collection database working in amarok 1.4 on 11.4 ?

One difference I notice in 1.4 in the configuration of “collection”, at
Settings > config amarok > collection

In 11.1: I have the choice of collection database: sqlite, mysql, postgresql. It is set at sqlite (the default I guess, never touched it).

In 11.4: I don’t even have the “Configure Database” section in “Collection”.

Tried banshee: junk
Tried gtkpod: works to copy to ipod, somewhat, but fails at cover album (and pretty much anything else as well!).

Thank you.

I have the same problem - Amarok 2.3, in KDE 4.5, worked fine. Clementine also has the same problem - and I’d not mess around with Amarok 1.4; you’ll be pulling in all sorts of deprecated stuff to get that to work in 11.4.

Googling around a bit seems to hint that part of the problem may be the transition to using udisks intead of HAL in KDE 4.6 (which is why more than one music manager is having this issue).

In any case, there’s an Amarok bug report here:

It’s targeted for a 2.4.1 release, and hopefully it’ll work.

Last I checked, gtkpod still worked if you need something now - it’s just not as friendly.

I use and don’t mind GTKPod, it does the job. Have you tried Banshee?

Banshee works once you fix up the usbmuxd issue (I filed a bug about it). I’ve been copying files on and off my iPhone ever since 11.4 came out using this method, works perfectly. I’d assume the iPod would work just as well.

If you want to use both Amarok 1.4 and 2.x you will have to start Amarok 1.4 with a shellscript to adjust the $PATH, otherwise scanning the collection doesn’t work.

On my machine I use the following script to start Amarok 1.4:

#! /bin/sh
PATH=$(echo $PATH | sed -e 's;:\?//usr/bin;;' -e 's;/usr/bin:\?;;')
PATH=$(echo $PATH | sed -e 's;:\?/opt/kde3/bin;;' -e 's;/opt/kde3/bin:\?;;')