Iphone in KDE

Hey all,
I’ve noticed there are a few threads started not only here but on other forums asking about gtkpod in KDE I was in the understanding that an iphone cannot sync with KDE as KDE detects it as a camera or an I missing something if so what packages do I need to get it to work in KDE.


I’m also having the same problem in my Samsung mobile.so please help me too.

How different is an iPod from an iPhone ? Note gtkpod works fine in KDE.

I just finished posting my openSUSE-11.3 to iPod Touch 3G interface experience here: Interfacing iPod Touch 3G to openSUSE-11.3 - Blogs - openSUSE Forums

@ vike4

Title of this thread is “Iphone in KDE”. Last I looked a Samsung mobile was not an Iphone. Or have I missed some Apple/Samsung agreement ?

You would be better off starting your own thread entitled : Help needed interfacing Samsung Mobile to openSUSE

Please start your own thread !

@oldcpu sorry i will post a new thread.

Thanks for posting that @oldcpu it don’t work for me, iphone syncing works great in Gnome, but just don’t in Kde.

Are you running gtkpod in KDE ?

I was successful with openSUSE-11.3 KDE-4.4.4 on on iPod Touch 3G and I know nothing about Apple devices so maybe my different configuration is a reason why.

What errors did you get when you adopted the approach I followed ?

yep have all installed that I should, no error output just no ones home but Kde detects it as a camera so I can navigate it that way but can not sync to upload music, this is no real big deal it works great in Gnome, im just interested as to why it don’t work.

Did you try IGNORING it as a camera (ie do NOT select to load the camera software) and creating a mount directory: /home/graemew66/ipod
and then mount it with:

ifuse /home/graemew66/ipod

Do you get any errors then ?

yes I always ignor it as a camera, no errors are reported, but still will not show up!

Note when I interfaced to my wife’s iPod Touch 3G from openSUSE-11.3, I did not get any popup indicating the iPod was interfaced correctly. I did get a popup asking to run digikam that I ignored.

I previously created the directory /home/oldcpu/ipod with:

mkdir /home/oldcpu/ipod

And then after plugging in the iPod Touch 3G (and ignoring the popup to connect to digikam) I typed:

ifuse /home/oldcpu/ipod

which then mounted the iPod Touch to the directory I PREVIOUSLY CREATED !

I still obtained no further popup.

Then I opened dolphin, and navigated to /home/oldcpu/ipod. I did a ‘refresh’ in dolphin (that is necessary to do, it is obvious and common sense) and I saw all the iPod directories.

My apologies, but when you type “still will not show up” it is so ambiguous I have no idea as to what you precisely tried and hence it is not possible for me to provide advice.

I assume also that you installed all the applications I noted : gtkpod, libgpod, libimobiledevice, ifuse, libplist, and usbmuxd but I also can not tell from your post if that is the case. It is clear thou - in my blog that I installed those.

And so maybe it is necessary to check the versions of those apps (so we can understand the difference) ? ie what is the output of:

rpm -q gtkpod
rpm -q libgpod
rpm -qa '*libimobile*'
rpm -qa '*fuse*'
rpm -q libplist
rpm -q usbmuxd

I also note that for the iPod Touch 4G it is necessary for THAT newer iPod to be Jailbroken (which is NOT the case for my wife’s older iPod Touch 3G). Is this also true for your iPhone of an unknown model/version (ie not provided by you) ? Is your iPhone Jailbroken and is it necessary for it to be Jailbroken ?

Ok I have some success I can now access the iphone folders in the /home/iphone folder but still the same problem only folders I can access this the camera side of the iphone, so now back to the original question why is it that gnome sees it as an iphone where as kde sees it as a camera what is it that gnome has that kde don’t??

I don’t know the difference between the camera side and the non-camera side. I do know using the method I noted, I can see many (not all) of the iPod directorys. Since I can see various music files and video files I assume I can see more than the camera side.

For transfering movies (via gtkpod) I have this working with KDE4 with an iPod Touch 3G. In KDE4 after mounting the iPhone as I noted (such that I can see it in Dolphin) I can then run gtkpod, and then CHANGE the directory in gtkpod where it looks. You HAVE TO DO THAT (ie point gtkpod to the directory where you have the iPhone mounted in KDE then gtkpod will see the iPhone. Obviously if you leave gtkpod looking at the Gnome file location for the iPhone it won’t see the iPhone. I had thought that intuitively obvious, so I assume you did that).

So from my view Gnome has nothing extra.

When you say you have it working such that you can access the folders in /home/iphone, what is the file manager? Please, I know this is frustrating but put youself in my shoes. How can I answer questions such as “why is it that gnome sees it as an iphone where as kde sees it as a camera what is it that gnome has that kde don’t??” when I have no idea as to what file manager software you are refering to. … You could be talking about terminal commands for all I know.

Anyway, glad to read you are making some progress.

First of all thanks for your help @oldcpu, but please understand that I’m not frustrated I mess around with this stuff just for kicks that’s what I meant by this is not a big deal!. So please I don’t wish to take up anymore of your time, this was just a question that if I have two pc that are exactly the same one with Gnome and one with kde even without gtkpod installed, if I plug my iphone 3gs in to the gnome one a message pops up saying Graeme’s iphone has been plugged in, now if I plug my phone into the kde a message pops up saying a camera has been plugin, I just think it is strange that since both are on the same base O/S what extra does gnome have that kde don’t, the ponderings of life.:\

Indeed, the implementations of the two desktops are strange … it illustrates a different implementation by the two different desktop development teams (Gnome vs KDE). The implementation of KDE is not perfect here, and I do not know how (nor who to contact to figure out how) to tune KDE to provide a more illuminating mount message.

I see others have struggled in the past with this: Opensuse 11.3 iphone support

I do plan to continue playing with my wife’s iPod (when she lets me) , and I’ll likely continue to use KDE4 to access/sync to the iPod and transfer files. It does work in KDE, but one does not get the same popup.

I stumbled across an excellent guide in the Portugese language on a SuSE sponsored (?) page, as to how one can connect their openSUSE to their iPad. The page translates reasonably well into English via Google: openSUSE Lizards - openSUSE/iPad interface (in Portuguese) and note one needs to translate via Google with something like: Google Translation of Portuguese article (I’m not sure how well that translation link will work).

I also stumbled across this page: User:Cabelo/LiMobile - openSUSE Now its NOT about interfacing iPhone to KDE4, but it is never the less interesting in terms of the applications included in this openSUSE distribution offshoot (based on SuSE Studio).

Of course my interest in this is not only from a “pure help others interst” and also my interest is not only from a desire to help someone with the iPhone, but rather its for my selfish learning, in the hope I can learn enough that I can better interface my KDE4 PC with my wife’s iPod and also have a good handle on this interface to help influence my decision as to which Tablet I ultimately purchase.