IP_tables lsst after update


I installed some updates yesterday to opensuse 11.1. After reboot, I get a fatal error that states that ip_tables not found. It suggests that my kernel needs to be upgraded (?).

Can someone please suggest me a fix? I would not want to reinstall the whole kernel, to avoid losing my settings. Also, I would want to avoid requiring a wired internet access. Can I download any patches and then run them to fix the problem?

I searched for solutions, but it seems to revolve around re-installing the kernel.

Can someone help?


Devendra :’(

ip_tables or iptables?

devendra rai wrote:

> I installed some updates yesterday to opensuse 11.1. After reboot, I
> get a fatal error that states that ip_tables not found. It suggests that
> my kernel needs to be upgraded (?).

Better copy/paste or transcribe the exact message you are getting and
specify in what stage is being displayed so people can get an idea of the

Anyway, you can check if the module is currently loaded by running:

lsmod | grep ip_tables



Show me the result of:

rpm -qa | grep kernel-default

Hello All,

Thanks for your time.

Here is what you asked for:

lsmod | grep ip_tables yielded nothing.
lsmod | grep iptables also yielded nothing.

The result of rpm -qa | grep kernel-default resulted in:

The exact error message is:
FATAL: Module ip_tables not found. iptables v1.4.2-rc1: can’t initialize iptables table ‘filter’: iptables who? (do you need to ins mod?
Perhaps iptables or your kernel needs to be upgraded

Any suggestions? I have a dual boot machine, so I am able to download required packages through Windows. Also, when I booted in safe mode (OpenSuse), my network manager would not run. I guess it is because of the iptables problem (or ip_tables).

Can someone help me in avoiding to do a kernel re-install?

Would really appreciate some guidance!

Thanks a lot!

Devendra Rai

iptables v1.4.2-rc1 is a newer version than what comes with 11.1, which has Have you installed some stuff from factory repos or something like that?

Yes. I ran automatic updates. Is there any way out of the mess that it created?

Thanks for your help!


It’s not the automatic updates, it’s that you probably have some bleeding edge repos in your subscription list which get you experimental versions of packages. Do this:

zypper lr

and post the results.

Hello ken_yap,

Here is the info that you wanted. I have had to insert an extra forward slash around colons to avoid making it look like smileys!

1 | 20090330-154311 | 20090330-154311 | Yes | Yes
2 | GNOME:Factory | GNOME:Factory | Yes | Yes
3 | KDE/:/KDE4/:/Factory/:/Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes
4 | NVIDIA Repository | NVIDIA Repository | Yes | Yes
5 | X11/:/XGL | X11/:/XGL | Yes | Yes
6 | devel:tools:building | devel:tools:building | Yes | Yes
7 | home:davjam79:perl | home:davjam79:perl | Yes | Yes
8 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
9 | repo | NVIDIA Repository | Yes | Yes
10 | repo-debug | openSUSE-11.1-Debug | No | Yes
11 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
12 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
13 | repo-source | openSUSE-11.1-Source | No | Yes
14 | repo-update | openSUSE-11.1-Update | Yes | Yes
15 | repo_1 | openSUSE BuildService - Wine CVS Builds | Yes | Yes
16 | repo_10 | openSUSE BuildService - X11:Compiz | Yes | Yes
17 | repo_11 | openSUSE BuildService - Drivers for webcams | Yes | Yes
18 | repo_12 | openSUSE BuildService - Games | Yes | Yes
19 | repo_13 | openSUSE BuildService - Mozilla | Yes | Yes
20 | repo_14 | openSUSE BuildService - Database | Yes | Yes
21 | repo_15 | openSUSE BuildService - PHP | Yes | Yes
22 | repo_16 | VideoLan Repository | Yes | Yes
23 | repo_17 | Packman Repository | Yes | Yes
24 | repo_18 | openSUSE Education | Yes | Yes
25 | repo_2 | openSUSE BuildService - GNOME:Community | Yes | Yes
26 | repo_3 | openSUSE BuildService - GNOME:STABLE | Yes | Yes
27 | repo_4 | openSUSE BuildService - KDE:Backports | Yes | Yes
28 | repo_5 | openSUSE BuildService - KDE:Community | Yes | Yes
29 | repo_6 | openSUSE BuildService - Mono:Community | Yes | Yes
30 | repo_7 | openSUSE BuildService - OpenOffice.org | Yes | Yes
31 | repo_8 | openSUSE BuildService - Virtualization (QEMU) | Yes | Yes
32 | repo_9 | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes

Hope it helps. Any help with the problem?



Yeah, with all those experimental repos, it’s a wonder you haven’t got yourself into a bigger mess.

Revert to the official iptables package from the OSS repo, and then disable the build service and bleeding edge repos.

As you can see, you have updated only kernel-default-base package
that includes minimal files and modules for booting.
Updating in addition to both kernel-default and kernel-default-extra packages
will solve this prpblem.

However, the situation now has become very troubling.
With kernel-default-base, in other words, without kernel-default,
you might not use network because kernel-default-base package includes only few drivers for NIC,
and therefore you might not use zypper command.
So you have to import kernel-default and kernel-default-extra packages
to your system without using network.

Hello ken_yap,

Thanks for the tip. How do I “revert”?

Also, I understand from your suggestion that I need to remove all those “build-service” repos, right?

Thanks for your expertise!

Devendra Rai

Go to YaST and search for iptables, then choose the last version from the OSS repo.

Maybe it might be better if you disabled all the non-core repos first.

Hello ken_yap and everyone!

Thanks for your time and patience with my question.

I successfully repaired my system. I found it easier (although a little longer) to just “upgrade” my openSuse. I ran the same installation disk for the purpose, and it did the job. I had to some minor settings after that, but, it was shorter than a fresh install.

I could not connect to the net (no NW manager, due to the problem). However, I removed all the “buildservice” repos, that I reckon are bleeding edge.

Thanks once again for your time!


Devendra Rai