IP settings

Toshiba laptop:
openSUSE 15.3
Wired connection

Conditions: Laptop is connected directly to the router via ethernet cable
Yast->network settings->overview->etho->edit
set to DHCP and accept.

bart@TOS-OS:~> ip addr | grep inet
    inet scope host lo
    inet brd scope global eth0

Internet connections work correctly

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=117 time=33.7 ms
64 bytes from icmp_seq=2 ttl=117 time=34.2 ms
64 bytes from icmp_seq=3 ttl=117 time=33.4 ms

Yast->network settings->overview->etho->edit
set to statically assigned ip address and accept.

bart@TOS-OS:~> ip addr | grep inet
    inet scope host lo
    inet brd scope global eth0

I can no longer reach internet.

bart@TOS-OS:~> ping        
connect: Network is unreachable


You need to make sure you go and add the gateway address on the routing tab…

AHA! Wish all mt problems were this simple! Thanks!

That should be the address of the router, correct?


Yup, your might also want to select the interface as well rather than -

I still think it is strange the OP has no default route defined.
He states that he set it to using DHCP. Then, IMHO, the route should be have been set by the DHCP server.

I misread it that way at first. However, if you look closely, it worked with DHCP. But he then switched to static IP assignment, which would lose that route from DHCP.

You are correct, I see it now.

But then he has to configure everything that DHCP will otherwise do for him: IP address/netmask, default route, DNS server, maybe even hostname.

There are several Tabs in that network configuration page, and you have to visit them all, at least to check what is there and if you need it.

That’s what caught me. I thought, although not correctly, that all the needed settings would be in one area. I knew that I needed a route, but as there was no entry where I set static address, I missed it on the other panels. My bad. But then the people here on this forum once again provided the needed help, and, most likely, in less time than I would have spent on hold had I called a “support line” :slight_smile: