ip forwading


Just installed opensuse 11.1.

I need to enable Ip forwarding. But if i enter Network service, pop out a msg, that Network is controlled by NetworkManager, and can not be edited with Yast. To edit setting use NetworkManager setting editor.

Any clue how can I enable Ip forwarding?


Open YaST and go to Network Devices -> Network Settings. In the Global Options tab select the Traditional Method instead of User Controlled. Now you can enable IP forwarding under Routing tab.
Good luck.


I have a similar problem myself.

I connect to the internet on my desktop (running openSUSE 11.1) using my Wifi card using WEP security, but my laptop is unable to get my hotspot’s signal. I am trying to IP forward it using bluetooth (Desktop bluetooth USB dongle to laptop wifi/bluetooth card) but to enable IP forwarding, I need to disable NetworkManager and use ifup, and ifup won’t allow me to input my WEP key in as hex (which should be right as my key is a 10-digit hex) and using ascii or passphrase doesn’t get me online.

In short It works ok using KNetworkManager, but not using the ifup method

This is how it should work
Winblows Laptop<-bluetooth->openSUSE Desktop<-80211b/g->Wireless Router<-DSL->Internet

This is what I get with NetworkManager
Desktop<-80211b/g->Wireless Router<-DSL->Internet

This is what I get with Ifup
Winblows Laptop<-bluetooth->openSUSE Desktop

Any help?