Inverted screen problem

Hello all.

I’m having a problem with my screen in opensuse 11.4.

Everything is ok until the login screen. After the login, when kde starts, the screen gets inverted, rotating 180 grades. The system performance is very slow when this happens. I tried to disable the KMS to use the default system driver, what worked. But with this option, I don’t have the performance and resolution available with KMS.

Anyone has a clue on that?


Personal Settings → Display and Monitor → Size & Orientation

There is a setting there for orientation, which allows you to rotate by 180 degrees. Perhaps that got set by mistake.

I think that this is not the problem, because with the KMS disabled I don’t need to rotate the screen, and the options are from system, right?

Another strange behavior occurs when I click in the inverted screen. Despite the orientation be 180 degrees inverted, the position of elements in the screen appears to be in the original position, because when I click in one item normaly doesn’t work, but when I click at the position that the item originaly be, the option gets activated.

Anyway, thanks for the reply!

How curious. I would have suggested similar to nrickert, but looks like you’ve encountered a bug. Anyway, more details about your graphics card could be useful

/sbin/lspci -nnk

Locate the lines pertaining to your graphics card and post here.

Is there any problem with you leaving KMS disabled? I presume you were using the ‘nomodeset’ kernel option in the relevant grub entry?

Hello @deano_ferrari, and thanks for the reply.

Yes, I’m using nomodeset kernel option and NO_KSM_IN_INITRD defined to yes.
It’s not a problem for me leave KSM disabled, but I prefer enabled, because I not yet configured the drivers manualy.

Well, my graphic card is an hybrid model, but reading in foruns I found that only the “native” intel graphics has support in linux kernel and nVidia doesn’t plan to support them at linux. Anyway, here’s the info:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18)
        Subsystem: Dell Device [1028:0468]

01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0df1] (rev a1)
        Subsystem: Dell Device [1028:0468]

Yeah, handling hybrid graphics is still a minefield in Linux, although there has been recent kernel development under way (vgaswitcheroo) to handle such systems

FWIW, have a read of this thread.

Even if you can get it to work with a new kernel, you’re restricted to using the open source drivers provided by the kernel.

Anyway, back to the topic…

  1. Did you try to install the nvidia driver by chance? I have seen some rumours online that suggest this can corrupt the intel graphics drivers from working correctly.
  2. Do you have a /etc/X11/xorg.conf at all? (Normally not, but maybe if you pursued trying to install the proprietary nvidia driver…). Or has this problem been present, since you first installed openSUSE?
  3. Can you disable the nvidia chipset totally within the BIOS? If so, do that, then re-enable KMS and see if the intel driver works correctly.

I didn’t heard about vgaswitcheroo yet, appears to be promissing!

Once I tryed to install nvidia driver, when I didn’t know that only the intel card works in my environment.

I don’t have a /etc/X11/xorg.conf, but I have some files at /etc/X11/xorg.conf.d/ that I edit when I want to test something, what appears to work.

The problem appeared after some time using openSuse 11.4, probably after an update, but I don’t remeber the files updated.

I’ll try to disable the Nvidia graphics in BIOS, but it’s not the ideal option since it will disable in Windows too, I’m using a dual boot environment.