invalid root filesystem

the latest factory kernel just gives me the statement: invalid root filesystem - switching to bin/sh or something.
The root partition is ReiserFS, at least I think it is.

This is usually because the supplied initrd does not contain the kernel module for your root filesystem’s type, in your case reiserfs. You have to run the Repair System from the DVD and rebuild the initrd. Before you do that, make sure that reiserfs is in /etc/sysconfig/kernel in the variable INITRD_MODULES.

from a factory dvd, or can I use any opensuse dvd?

You should preferably use the same release as your main installation, though it probably isn’t very critical since the Repair System boots to its own environment, you only need the tools on it to be roughly the same vintage as the distro.

Try powering off your computer. Don’t know what’s doing it exactly, but I had the strangest GRUB-errors, they disappeared after completely unplugging and rebooting the system.

now I have done the things with rescue system, mkinitrd and still the same.

BTW. my root fs was ext3, it was my previous root-fs that was reiser.

It’s some other reason then, that I don’t know about. Is your GRUB stanza correct? Are you trying to mount the correct partition and not some other one?

after my last post I thought it could be GRUB, but the grub config looks right.

Right boot-img
Right vmlinuz
Right partition

What about required disk controller modules, are they all in the initrd?

Are you able to mount the partition from the rescue system, loading needed modules manually if necessary?

yes, I belive, when I checked it did look OK, sata_nv and so on. It was just like it were before.

Partiton mounts in rescue, yes, without anything fancy, just; mount /dev/sda3 /mnt

Could be a bug, after all, it’s Factory.

yes, I know, maybe a problem with mkinitrd?
the same message comes when trying to start the latest pae-kernel from 11.1 update repo.
It worked before running mkinitrd

well, i got this message for all kernels.
first time i encountered it, when i upgraded to factory kernel 07-March. Just after upgrade this kernel start throwing this message on boot, but my hand-installed kernel still worked(if factory X issues don’t count). After that i downloaded latest RC kernel from, and installed it (and i called mkinird). And now all my kernels complain on invalid root filesystem :frowning:

Maybe someone help, how to return my system to life again? (rootfs is ext3 and mounts without problems in the resq shell)

What you are explaining is exactly the same as the problem I got. I think it is something with the mkinitrd command, but are not sure.

tried factory mkinitrd, it did not work either…

anyone that has any idea, I am open to try

reverting to the kernel from 11.1 is not a alternative, since it freeze almost instantly after boot.

I still think it’s some missing module. When it says invalid root filesystem and drops you into a shell, can you do a lsmod and note down the modules loaded? Then compare with the list of modules loaded at the rescue system when you are able to mount.

Double check that the vmlinuz and initrd in /boot are pointing to the correct versions, those are symlinks that are moved when the kernel is upgraded.

I think you’ve destabilized your system. Reinstall would be my advice.

This is a major problem and I’m having it too.

I have a system with /dev/md0 as the root filesystem with ReiserFS formatting.

After upgrading from kernel-default- (the openSUSE 11.1 default) to kernel-default- (which comes from 11.1 updates), my system would no longer boot!

Workaround I’ve found so far: when boot fails and you fall into a shell script, run “modprobe reiserfs”, then hit CTRL-D.

I inspected my initrd and it seems to have reiserfs configured in there (it’s also in /etc/sysconfig/kernel in INITRD_MODULES).

I filed a bug: