Invalid PBLK length and esas2r driver error


Recently, a relative has given me a computer they found after cleaning up, and don’t need anymore (I remember them using it a long ago, but probably stopped using it because of this error or their lack of Linux technical knowledge). I also have another PC, with Windows 7 Pro and a bit of old age (also given to me by that same relative, computer was bought 10-12 years ago), but it runs. I remember said relative using this PC for work-related reason, and also for their son to play on, and I at one point ended up using it once, and I was confused with the layout, but it did work perfectly (there also was something about GNOME, if this ever is related). Upon inspection, the new computer, with openSUSE, and an HP BIOS (though it has very little options) has much better specs than my current one, which is a fossil at this point, so I unplug my current PC, and plug everything into the new one, overjoyed.

After booting it up, I get a screen tinted in green with the openSUSE logo (note that I did not know the OS was openSUSE before booting, all I know is GNOME) and two options :

*=left]openSUSE Leap 42.1
*=left]Advanced options for openSUSE Leap 42.1

*=left] openSUSE Leap 42.1, with Linux 4.8.7-33-default
*=left] openSUSE Leap 42.1, with Linux 4.8.6-33-default
*=left] openSUSE Leap 42.1, with Linux 4.1.36-44-default
*=left] openSUSE Leap 42.1, with Linux 4.1.34-33-default

The first time, I went openSUSE Leap 42.1, but no matter what option I choose, I always end up with an error. The error being ;

    0.950624] acpi LNXCPU:00: Invalid PBLK length [7]
    0.950638] acpi LNXCPU:01: Invalid PBLK length [7]
    0.950649] acpi LNXCPU:02: Invalid PBLK length [7]
    0.950624] acpi LNXCPU:03: Invalid PBLK length [7]
    1.815507] esas2r: driver will not be loaded because no ATTO esas2r devices
Warning: Boot has failed. To debug this issue add " rd.debug" to the kernel command line.


(This is my last launch, I typed everything word for word, also the times are almost identical each run)

Seemingly, no matter how long I wait, it does not proceed. So I looked it up and accidentally pressed “e” on the build menu, and accessed Grub, though I had no idea of what I was doing. I messed around with Grub to no avail. I then read online to add “ rd.debug” at the end of the ‘linux’ string in the code appearing when you press “e”, and pressed F10 and finally accessed the Linux Bash shell. I also had no idea of what to do, but the CMD-like directory system and terminal I associated with Windows, so I tried going around folder and files. Still no idea of what to do. I eventually do a bunch of reading, then copy a Windows 7 ISO to a USB I had laying around, plug it into the new PC, and try to boot it someway, but nothing worked.

Now I’ve decided to just fix the main problem and try to land into the desktop and run an ISO from there.

Specs (from BIOS) :

Product Name ------------------- HP Compaq 6000 Pro MT PC
SKU Number --------------------- BU594US#ABC
Processor Type ----------------- Intel(R) Core(TM)2 Quad CPU Q9500 @ 2.83GHz
Processor Speed ---------------- 2833/1333 MHz
Processor Stepping ------------- 0001067A 00000A07
Cache Size (L1/L2) ------------- 64KBx4 / 3072KBx2
Memory Size -------------------- 8192 MB DDR3/1066 MHz/Dual Channel
-- Channel A ---------------------- XMM1 4096 MB / XMM2 0 MB
-- Channel B ---------------------- XMM3 4096 MB / XMM4 0 MB
Integrated MAC ----------------- 0023240796E8
System BIOS -------------------- 786G2 v01.12
Chassis Serial Number ---------- CAC02304TL
Asset Tracking Number ---------- CAC02304TL
ME Firmware Version ------------
Management Mode ---------------- AMT

Please help, I’ve been trying for the last two days, and no matter where I look, I have too little understanding of Linux terms to know what to do. Please explain this in the simplest way possible or please explain terms (I still know how to operate a computer and can code, I just don’t know much Linux). I’m always here, ask me anything, and if I ever take time to reply, I’m probably trying your solution before replying.

Thank you very much :).

I wouldn’t put any more effort into this Leap installation as the support for Leap 42.1 ended May 2017 anyway. Download a new installer image here and install it. There is absolutely no sense in trying to get this old installation to run unless you want the see what is stored on the platter (but for this case other possibilitys exist).

Edit : I fiddled around with grub and the USB and finally booted into it, and finally installed Windows. Thread closed.