Invalid Module Format when trying to load r8168

Have an installation of OpenSuSE-11.1
on a Core-i7 based machine with a Gigabyte
motherboard.
This has dual network card,
and after some intitial problems with
networking, I downloaded the r8168
driver (8.011.00) from the Realtek support page
and got networking to run.

Yesterday, the machine was updated
and apparently a new kernel was included
in the update.
2.6.27.19-3.2 was replaced by 2.6.27.21-0.1

After this update this module was no
longer available so I recompiled.

$ make clean modules
$ make install
$ depmod -a
$ modprobe r8168

When I did “modprobe r8168” it failed
to load with the error message
“invalid module format”

I then tried recompiling another module
for a USB serial port, getting the same
“Invalid module format” error message during load.

If I modprobe the new module built under
2.6.27.21-0.1 it fails.
If I modprobe the old module compiled
for 2.6.27.19-3.2 it loads, but does not
do any good.

Any clues?

Hi
Grab the pre-built module from here instead…

http://download.opensuse.org/repositories/drivers:/nic/openSUSE_11.1_update/

r8168-kmp-default-8.011.00_2.6.27.21_0.1-1.2.x86_64.rpm


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
up 1 day 1:06, 1 user, load average: 0.49, 0.21, 0.13
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

dmesg gives:
“r8168: no symbol version for struct_module”

The kernel is compiled with
CONFIG_MODVERSIONS=y
and you apparently have to compile the module
with the same CONFIG_MODVERSION=y
to make it work.
$ uname -r
2.6.27.21-0.1-default
$ grep CONFIG_MODVERSIONS /lib/modules/2.6.27.21-0.1-default/build/.config
CONFIG_MODVERSIONS=y
so I think I am OK there.

OK, I tried that, and that modprobe works,
but I still do not get any network.
I saw that r8169 was loaded and there appears
to be a connection between r8169 to the mii module.
When I remove the r8169 there is no connection
to the r8168 module in the same way.

eth0 and eth1 does not exist.
Only lo and pan0

Tried removing the network cards
and reinstalling them.
I do no get any alternatives for drivers
in the dropdown list, and if I write r8168
it disappears :frowning: