Invalid module format - libafs


I’m using openSUSE 11.2 and try to get openafs working (OpenAFS). The libafs.ko module is being built, but when I try to load it, I get the error Invalid module format:

root@tajuna # modprobe libafs   
FATAL: Error inserting libafs (/lib/modules/ Invalid module format

I tried to search the forums, but couldn’t find the answer to this problem.

I’m using the kernel:

 root@tajuna #uname -a
Linux tajuna #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

and as far as I understand, the module has been built for this kernel:

modinfo libafs                                                           
filename:       /lib/modules/
srcversion:     CF61543D718F156F74D9E3C
vermagic: SMP preempt mod_unload modversions 
parm:           sys_call_table_addr:Location of system call tables (array of long)
parm:           probe_carefully:Probe for system call tables carefully (int)
parm:           probe_ignore_syscalls:Syscalls to ignore in table checks (array of int)

Could anyone give a hint how to get this module working?


You have a 64bit system, could it be your compiled module is 32bit?

Thanks for the reply. I didn’t think so, but to be sure I did a new configure and make, with amd64_linux26 as option:

./configure --prefix=/usr/local --with-afs-sysname=amd64_linux26 --with-krb5 KRB5CFLAGS=-I/usr/include KRB5LIBS=-lkrb5

But with the same result. Also, the file format is really x86-64:

root@tajuna # objdump -f libafs.ko

libafs.ko:     file format elf64-x86-64
architecture: i386:x86-64, flags 0x00000011:
start address 0x0000000000000000

So I assume it really is the right format…

We’re both barking up the wrong tree !!! Take a look here:
and search for ‘openafs’ :slight_smile: ready made packages are being served.

If I were you I’d run a ‘make uninstall’ before installing the package.

Good luck

Thanks again!

I also found this website AFS .

I removed the library, followed the instructions, installed the following packages:

-rw-r--r-- 1 1.6M Jun  8 14:15 openafs-1.4.12-6.8.x86_64.rpm
-rw-r--r-- 1 471K Jun  8 14:15 openafs-client-1.4.12-6.8.x86_64.rpm
-rw-r--r-- 1 912K Jun  8 14:15 openafs-kernel-source-1.4.12-6.8.x86_64.rpm
-rw-r--r-- 1 135K Jun  8 14:15 openafs-krb5-mit-1.4.12-6.8.x86_64.rpm

But unfortunately I keep getting the invalid format error:

root@tajuna # /etc/init.d/openafs-client start
Starting OpenAFS Client 
FATAL: Error inserting libafs (/lib/modules/ Invalid module format

It’s a bit frustrating, to get this after I used the packages… :expressionless: I hope find the problem soon.

Any help is still welcome :slight_smile:

This contains the kernel module for the 11.2 kernel:

Install that one, and return with results.

Great, thanks, it works now :smiley: