"invalid filesystem type" mounting phone as memory card

I’m new to openSUSE, having spent much time drinking the M$ koolaid prior. Now I’m trying to set my home PC up to give it a fair test with Linux. So, please forgive my ignorance.

I have a Motorola SLVR L7 phone, running iTunes on it. When I plug the phone in while in openSUSE 11, the display changes to indicate that it is connected as a storage device (it contains a 1GB transflash card that shows up as a removable drive in Windows). Then on the computer I am presented with a screen stating that new media was found (it names the volume name I gave the card) and asking me what I would like to do; view the files on the device, transfer photos, or nothing. When I choose to view the files, it tells me “invalid filesystem type” and shows nothing. If I open my computer and go to media, I see the device, and it has the image of an iPod, but right-clicking it and trying to mount it results in the same error.

I believe that this should basically just show up as a removable memory card, right? So, what am I missing? I would love to try out this Amarok program, but without at least being able to transfer my music to and from the device, I’m pretty much stuck. :frowning:

I have an issue with dual monitors too, but that’s a post for another day… :wink:

I really appreciate your help! Thanks in advance!

Never mind, I guess…

I tried booting into Ubuntu to see what its fstab file, etc, looked like and maybe find out why it just works. Then I rebooted with my phone still plugged in, and when openSUSE came up it was recognized!

I just went through some simple configuration in Amarok and I could browse my phone!

So…I guess sometimes the ode to Windows applies here as well: “If all else fails, reboot!”