Invalid "factory" repositories

Hi all,

I have been unable to find a solution to the following problem with some open-suse tumbleweed repositories. The zypper ref command gives this:

leo67@linux-mhs1:~> sudo zypper ref
[sudo] password for root:
Repository ‘Visual Studio Code’ is up to date.
Repository ‘openSUSE:Tumbleweed’ is up to date.
Repository ‘home:Herbster0815’ is up to date.
Repository ‘home:ecsos:Backup’ is up to date.
Retrieving repository ‘openSUSE:Factory:Staging’ metadata …[error]
Repository ‘openSUSE:Factory:Staging’ is invalid.
[http-download.opensuse.org-28ea6f20|http://download.opensuse.org/repositories/openSUSE:/Factory:/Staging/standard/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘openSUSE:Factory:Staging’ because of the above error.
Retrieving repository ‘openSUSE:Factory:Staging’ metadata …[error]
Repository ‘openSUSE:Factory:Staging’ is invalid.
[http-download.opensuse.org-3eb0f066|http://download.opensuse.org/repositories/openSUSE:/Factory:/Staging/standard/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘openSUSE:Factory:Staging’ because of the above error.
Retrieving repository ‘openSUSE:Factory:Staging’ metadata …[error]
Repository ‘openSUSE:Factory:Staging’ is invalid.
[http-download.opensuse.org-7a85da81|http://download.opensuse.org/repositories/openSUSE:/Factory:/Staging/standard/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘openSUSE:Factory:Staging’ because of the above error.
Retrieving repository ‘openSUSE:Factory:Staging:A’ metadata …[error]
Repository ‘openSUSE:Factory:Staging:A’ is invalid.
[http-download.opensuse.org-9e91859f|http://download.opensuse.org/repositories/openSUSE:/Factory:/Staging:/A/bootstrap_copy/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘openSUSE:Factory:Staging:A’ because of the above error.
Repository ‘home:fusion809’ is up to date.
Repository ‘home:twotaps:branches:home:Herbster0815’ is up to date.
Retrieving repository ‘openSUSE:Factory:Staging’ metadata …[error]
Repository ‘openSUSE:Factory:Staging’ is invalid.
[http-download.opensuse.org-ba45d9e1|http://download.opensuse.org/repositories/openSUSE:/Factory:/Staging/standard/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘openSUSE:Factory:Staging’ because of the above error.
Repository ‘openSUSE:Factory:Staging:A’ is up to date.
Repository ‘openSUSE:Factory’ is up to date.
Repository ‘packman’ is up to date.
Repository ‘openSUSE-Tumbleweed-Non-Oss’ is up to date.
Repository ‘openSUSE-Tumbleweed-Oss’ is up to date.
Repository ‘openSUSE-Tumbleweed-Update’ is up to date.
Some of the repositories have not been refreshed because of an error.
leo67@linux-mhs1:~>

This is the same issue on my laptop and desktop with opensuse.

Hi
None of the repositories your having issues with are ‘standard’ tumbleweed repositories, factory is for testing only, not day to day usage…

It could be related to https://bugzilla.opensuse.org/show_bug.cgi?id=1123967 or mirror state inconsistency at the time you are trying to use them. Also likely is some combination of all those other repos not part of standard TW, as malcolmlewis indicated. Try disabling all except Packman, OSS, Non-OSS and Update, then refreshing and duping. If you actually need any of the others, add back and use one at a time until you reach whatever state you require that demands more, then disable all but the standard ones again.

Thx, seems to have worked. I did not realize (a bit new to opensuse) that “factory” was the “testing” repositories.