Invalid Ext4 Partition on Thumb Drive

It hangs when trying to manual mount the drive.

***You can never know everything, but you can keep trying till you die, because knowledge IS power and great power can bring great prestige.***​ - Tyler McCalley

Then try to see if something can be repired there:

fsck -t ext4 /dev/sdc1

Ok I did the manual mount and it finally mounted to /mnt then i unmounted the drive and now it auto mounts for some reason or another. I didn’t even have to do the fsck to get it to mount. wow this is really weird. sorry if I wasted to much time here but I really appeciate the help. Are there any websites that break down tux so that I can learn its system files and functions to learn more about being an administrator over tux systems?

Really thank all of you sooo much for the help.

***You can never know everything, but you can keep trying till you die, because knowledge IS power and great power can bring great prestige.​ - ***Tyler McCalley

The world is full of magic, even in the world of computers.

On 05/11/2013 03:26 PM, mccalleyt wrote:
>
> Ok I did the manual mount and it finally mounted to /mnt then i
> unmounted the drive and now it auto mounts for some reason or another. I
> didn’t even have to do the fsck to get it to mount. wow this is really
> weird. sorry if I wasted to much time here but I really appeciate the
> help. Are there any websites that break down tux so that I can learn its
> system files and functions to learn more about being an administrator
> over tux systems?

As long as you pull the plug without unmounting the file system, you will have
to manually fix it. You really do need to learn the correct procedures, or mount
it read-only. When read/write, you risk losing files when you do not dismount
correctly.

On Sat, 11 May 2013 18:46:05 +0000, mccalleyt wrote:

> Here is the fdisk -l output for ya it does show that it has a valid
> partition.

OK, that’s a good step.

Next step is to try manually mounting the partition:

sudo mount /dev/sdc1 /mnt

What is the output from that command?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Well it does mount correctly now. I’m not sure what did the trick but I am going to take the advice to change the filesystem to ext4 without journaling.

My guess is that it was not closed properly thus had unwritten journal entries. The auto loader saw this and thought it was mounted or corrupt. Mounting by hand and a proper umount flushed the journal and thus allowed the auto mount.

In future never always tell the system to un-mount the device before pulling it. This can cause lost data as well as mount problems. Also use a non-journal file system or option for removable devices.

On 2013-05-12 21:56, gogalthorp wrote:
> In future never always tell the system to un-mount the device before
> pulling it. This can cause lost data as well as mount problems. Also use
> a non-journal file system or option for removable devices.

Just a detail: I think we can use journals on removable devices, if they
are normal magnetic disk. It is a problem for flash media, because they
wear out.

However, I do not know if there may be another type of problems with
journals on rotating, external, hard disks. Ie, when there is a danger
of the cable being disconnected, is it preferable to have a journal or not?


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 05/12/2013 05:43 PM, Carlos E. R. wrote:
>
> However, I do not know if there may be another type of problems with
> journals on rotating, external, hard disks. Ie, when there is a danger
> of the cable being disconnected, is it preferable to have a journal or not?

I think it is better. Without a journal, all pending writes are lost. With a
journal, all in the journal will be recovered. You need an fsck in either case.

Theoretically journal is there exactly to protect filesystem integrity in such cases.

There is no reason not to have a journal on any device if you properly umoint before removing. The problem is if you just jerk the device out the journal may be left uncommitted and you are left with a device you can’t auto-mount. So fschk is needed or sometimes just a mount umount to force the commit.

You really got it backwards. If you always have chance to properly unmount, there is no need to have a journal. Journal is needed exactly to protect you from accidental device removal.

I keep trying to do a fsck on the drive and it says it is busy. I checked it isn’t mounted so how can I look at certiain files or devices to see what is accessing those items? Plus does anyone have good advise on what websites to goto or free ebooks to get to learn linux systems in and out…

On 2013-05-13 10:26, arvidjaar wrote:
>
> gogalthorp;2556398 Wrote:
>> There is no reason not to have a journal on any device if you properly
>> umoint before removing.
>
> You really got it backwards. If you always have chance to properly
> unmount, there is no need to have a journal. Journal is needed exactly
> to protect you from accidental device removal.

Yes, it makes that the required fsck the next time runs much faster.
However, what is protected is the metadata, not the data changes
themselves (optional, I think).

That is, after the fsck the files are there, all the sectors are listed
and assigned, but maybe they don’t contain what you expect.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-05-13 15:26, mccalleyt wrote:
>
> I keep trying to do a fsck on the drive and it says it is busy. I
> checked it isn’t mounted so how can I look at certiain files or devices
> to see what is accessing those items?

Run the command “mount” and verify that it is not really mounted. If it
is, use the command “umount /dev/whatever” to umount it.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thanks Carlos, but I have tried doing the umount on the device with no evail Its won’t let me fsck it says the device is in use or busy.

You must stop telling stories. You must show the computer actions.

Thus you show from prompt to prompt what hapens when you do the umount command!

This is ot the firt time that that is explained to you.

On 2013-05-13 16:26, mccalleyt wrote:

> Thanks Carlos, but I have tried doing the umount on the device with no
> evail Its won’t let me fsck it says the device is in use or busy.
>

Prove it :slight_smile:

I want to see the commands used, complete with outputs in the same
block, pasted here inside code tags. We are non-believers here :stuck_out_tongue_winking_eye:


# mount
.....
.....
# umount -v whatever
.....
# fsck whatever
.....


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On Sun, 12 May 2013 19:56:02 +0000, gogalthorp wrote:

> My guess is that it was not closed properly thus had unwritten journal
> entries.

That would be my guess too - it’s important to properly umount the device
before pulling it out of the USB port. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C