intltool error

i have an error with intltool when './configure’ing. whenever i type ./configure it runs through a list of commands and things. at the end it says:

checking for intltool >= 0.35.0… awk: cmd. line:1: fatal: cannot open file ./intltool-update.in' for reading (No such file or directory) awk: cmd. line:1: fatal: cannot open file ./intltool-update.in’ for reading (No such file or directory)
found
./configure: line 7198: test: : integer expression expected
configure: error: Your intltool is too old. You need intltool 0.35.0 or later.

i downloaded and installed intltool 0.37.1-17.1 using YAST2
the error still occurs.
this may be a blatantly obvious error for you pros, but i am new at linux.
Thanks in advance

Hi
That indicates the file called ‘intltool-update.in’ doesn’t exist in
the directory, hence the error. Is there something in the readme or
install file supplied with the package? Run configure with --help as
there may be an option your missing? Generally it also helps (well me
anyway) to say what package you downloaded or did it come via cvs etc
and are trying to build.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 0:52, 1 user, load average: 0.80, 0.29, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

oh. well im trying to install dldi-linux-gui which is from:

SourceForge.net: Files

i read the install file and it told me to get some C++ Bindings:

To compile DLDI Linux Gui, you’ll need the dbus C++ Bindings of the OpenWengo project. Get it from their subversion repository.

svn co https://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs/dbus dbus-c++

cd to that directory
cd dbus-c++

Run configure WITH --enable-glib
./configure --enable-glib

Compile and install it
make
sudo make install

When i got to ./configure --enable-glib it said:

bash: ./configure: No such file or directory

i tried configure --help but it said ‘command not found’

How do i fix the initltool problem?

Thanks in advance

Hi
Try running ./autogen.sh first that should build the configure script.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 16:09, 2 users, load average: 0.26, 0.67, 0.49
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

i did the ‘./autogen.sh’ which worked. i then could do the ‘./configure’. which also worked. however, when i do ‘make’ i get an error:

object.cpp:113: error: ‘strncmp’ was not declared in this scope
make[1]: *** [object.lo] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src’
make: *** [all-recursive] Error 1

whats this telling me? how do i fix it?
thanks in advance

Hi
I would say that’s an issue with gcc4.3 and strict headers. L R Nix
will probably be online soon and hopefully she will have an idea on a
fix :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 20:00, 2 users, load average: 0.29, 0.20, 0.24
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

On Tue, 19 Aug 2008 16:29:27 GMT
Malcolm <malcolm_nospamlewis@bellsouth.net> wrote:

>

> Hi
> I would say that’s an issue with gcc4.3 and strict headers. L R Nix
> will probably be online soon and hopefully she will have an idea on a
> fix :slight_smile:
>

NOW I know why my ears were burning…

Hi guys!

Let’s see… one of those “error: ‘x’ was not declared in this scope”
thingy’s again huh?

Simple!!

This error is because of updates to the gcc/g++ compilers to make them
conform better to the standards. The header files were revamped and do not
“helpfully” include extra headers any more.

So… to fix…

Look at the offending function call… in this case: “strncmp”

Anyone know what header it’s from? Well, look it up in the man pages:

man strncmp

in the SYNOPSIS section right at the top of the text is “#include <string.h>”,
which is for a C program… so we need to make it work for a C++ program…
(press ‘q’ to exit the man page viewer)

drop the ‘.h’ and put a ‘c’ in front… thus we have “cstring”

Add the following line to the object.cpp (right? that’s what’s shown in the
error message)

#include <cstring>

You’ll need to find any other ‘#include’ statements in the source file, and
put this new one just after them.

Hopefully (!) this made sense, and you’ll be able to take care of any other
error messages like this that occur. Over time, more people will use the new
gcc/g++ versions (4.3.1 and newer I think) and this problem will fade.

Loni


L R Nix
lornix@lornix.com

confused… that didnt make any sense for me sorry. also i dont have manual pages for strncmp: ‘no manual entry for strncmp’ would it be possible for you to rewrite the instructions so they are more user friendly please?

thanks anyway

i put #include <cstring> into object.cpp and ran make again. however i have a new error:

types.cpp:69: error: ‘free’ was not declared in this scope
make[1]: *** [types.lo] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src’
make: *** [all-recursive] Error 1

i am a real newbie at all this, so dont blame me for being ignorant.

thanks

On Wed, 20 Aug 2008 09:36:03 GMT
DrEaMeR23 <DrEaMeR23@no-mx.forums.opensuse.org> wrote:

>
> i put #include <cstring> into object.cpp and ran make again. however i
> have a new error:
>
> > types.cpp:69: error: ‘free’ was not declared in this scope
> > make[1]: *** [types.lo] Error 1
> > make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src’
> > make: *** [all-recursive] Error 1
>
> i am a real newbie at all this, so dont blame me for being ignorant.
>
> thanks
>
>

You should see that you have the ‘man-pages’ package installed, it helps with
many things.

The line for this one is:

#include <cstdlib>

Loni


L R Nix
lornix@lornix.com

done that new message:

message.cpp:355: error: ‘free’ was not declared in this scope
make[1]: *** [message.lo] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src’
make: *** [all-recursive] Error 1

do i have something wrong with my linux because i have this many errors?
also where do i get the man pages from? ther not in my repository (in english) theres other languages like spanish and french.

Hi
I would say you need to add (but I’m sure L R Nix will pipe in if not,
I’m sure her ears are starting to burn again);

#include <cstdlib>

No nothing wrong, it’s the new gcc version. Takes a while for the
developers to catch up :slight_smile:

Most packages include the man pages, else google is your friend :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 17:48, 2 users, load average: 0.75, 0.22, 0.14
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Guess what… new error a long one this time:

xml2cpp.cpp: In function ‘void usage(const char*)’:
xml2cpp.cpp:58: error: ‘exit’ was not declared in this scope
xml2cpp.cpp: In function ‘int char_to_atomic_type(char)’:
xml2cpp.cpp:78: error: ‘strchr’ was not declared in this scope
xml2cpp.cpp: In function ‘const char* atomic_type_to_string(char)’:
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:102: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp: In function ‘void _parse_signature(const std::string&, std::string&, unsigned int&)’:
xml2cpp.cpp:135: error: ‘exit’ was not declared in this scope
xml2cpp.cpp:171: error: ‘exit’ was not declared in this scope
xml2cpp.cpp: In function ‘void generate_proxy(DBus::Xml::Document&, const char*)’:
xml2cpp.cpp:201: error: ‘exit’ was not declared in this scope
xml2cpp.cpp: In function ‘void generate_adaptor(DBus::Xml::Document&, const char*)’:
xml2cpp.cpp:504: error: ‘exit’ was not declared in this scope
xml2cpp.cpp: In function ‘int main(int, char**)’:
xml2cpp.cpp:927: error: ‘strncmp’ was not declared in this scope
make[1]: *** [xml2cpp.o] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/tools’
make: *** [all-recursive] Error 1

how do i work out the code line (#include…)? so i dont have to keep bugging you. is it possible to change it from the .tar.gz to a .rpm? so i dont have all these make problems?

Hi
So I see the strcmp error again so that’s cstring, cstdlib (maybe) and
do you have the xml2 devel files installed?

The only way you can do that is feedback to the developer of all the
errors :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 18:29, 2 users, load average: 0.16, 0.19, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

yes i do have xml2-devel installed. when you say cstdlib do you mean put in #include <cstdlib> like before?

I have done that and… more errors

xml2cpp.cpp: In function ‘int char_to_atomic_type(char)’:
xml2cpp.cpp:79: error: ‘strchr’ was not declared in this scope
xml2cpp.cpp: In function ‘const char* atomic_type_to_string(char)’:
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp:103: warning: deprecated conversion from string constant to ‘char*’
xml2cpp.cpp: In function ‘int main(int, char**)’:
xml2cpp.cpp:928: error: ‘strncmp’ was not declared in this scope
make[1]: *** [xml2cpp.o] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/tools’
make: *** [all-recursive] Error 1

thanks for all the help so far

Hi
Yes, same as before, but also the as so perfectly described by
the coding guru L R Nix.


#include <cstdlib>
#include <cstring>


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 21:32, 2 users, load average: 0.08, 0.15, 0.25
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

> > to ‘char*’
> > xml2cpp.cpp:103: warning: deprecated conversion from string constant

Warnings may be ignored.

You’re doing good, work through the errors as you encounter them. Again,
these won’t occur if you use an older compiler… but the older compilers
have bugs and problems, so you’re better off using the new compiler.

May I ask… what is it that you’re trying to compile? And is it already
available in YaST?

Loni


L R Nix
lornix@lornix.com
coding guru now huh?

its still saying the

xml2cpp.cpp:104: warning: deprecated conversion from string constant to ‘char*’

but then it carries on. new error now.

introspect.cpp:57: error: ‘strcmp’ was not declared in this scope
make[1]: *** [introspect.o] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/tools’
make: *** [all-recursive] Error 1

i used #include <cstdlib> to fix that because its the strncmp thingy. but something else has arisen

introspect.cpp:59: error: ‘strcmp’ was not declared in this scope
make[1]: *** [introspect.o] Error 1
make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/tools’
make: *** [all-recursive] Error 1

Hi
Its a prerequisite to some other app the OP is trying to compile (I had
a look no rpms…) It finally got the better of me, so I did download
myself… and have come up with the following on this system;


svn co
https://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs/dbus
dbus-c++

cd dbus-c++/

cat /usr/share/aclocal/libtool.m4 > aclocal.m4

../autogen.sh
Running libtoolize...
Running aclocal...
Running autoheader...
Running automake...
configure.ac:6: installing `./install-sh'
configure.ac:6: installing `./missing'
examples/echo/Makefile.am: installing `./depcomp'
Running autoconf...
Autogen done, now you can ./configure

../configure --enable-glib --prefix=/usr

Error 1
vi src/object.cpp
#include &lt;cstring&gt;

Error 2
vi src/types.cpp

#include &lt;cstring&gt;
#include &lt;cstdlib&gt;

Error 3
vi src/message.cpp

#include &lt;cstdlib&gt;

Error 4
vi src/glib-integration.cpp

#include "eventloop.h"
#include "dispatcher.h"

Error 5
vi tools/xml2cpp.cpp

#include &lt;cstdlib&gt;
#include &lt;cstring&gt;
Change line 86 static struct { char type; const char* name; } atos] =

Error 6
vi tools/introspect.cpp
#include &lt;cstring&gt;

Error 7
vi examples/echo/echo-server.cpp
#include "netdb.h"

make

Left with the following warning;

dispatcher.cpp:69: warning: ‘int dbus_watch_get_fd(DBusWatch*)’ is
deprecated (declared
at /usr/include/dbus-1.0/dbus/dbus-connection.h:370)


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 1 day 22:57, 2 users, load average: 0.05, 0.58, 0.57
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12