I wanted to update to 42.1, so I dowloaded, burned an ISO 9660 CD, rebooted from the CD with “Upgrade”-option, and everything worked fine until the upgrade from the CD was finished. Obviously, the machine was still working (disk lamp blinking at intervals), so I left it running. Then the network connection died. After
some back and forth with the provider’s support, I restarted modem and router and PC.

Now, I got the message that there would be no update since the network connection (WIFI) was not running. So I ckecked my connection, that was up and running. Next I did an ‘/sbin/route’, WIFI seemed OK. Reebot, situation remained. Connected via cable, ‘/sbin/route’ again, everything seemed to be OK. Still no network connection (pinging failed as well).

I suspect that the situation may be remedied by som intelligent utilization of network manager, but there may be other ways. So any help/suggestion would be most welcome.

Remark: I could have posted the above in the Network/Internet forum, but since the problem popped up with update to Leap 42.1, I posted here.

Thanks in advance,
Jan Christian

Case solved. YAST was the solution. Changed network adapter to wlan0, that did it.

Sorry for bothering,
Jan Christian
(who is wondering why this was changed during update)

Refer Leap release notes (always worth a read):