Internet will not connect

I am running Suse 11.4 with a Gnome desktop.
I have just tried to connect to the Internet, but the computer can find no connection. The same story with my email.
These both worked fine when I turned the computer off last night.
I plugged the ethernet cable into another computer running 11.1 and it connected without problem.
Something appears to be wrong with my 11.4.
I have made no adjustments at all to anything.
Can anybody help me re-connect?
Many thanks.

Do you have a live CD? If you boot it, does internet work?

Are there any other OS on this machine? Do they work?

There are no other OS on the computer.
I don’t know what you mean by a live CD -so probably don’t have one!

Live CD is one of the install options. It boots to a live desktop.
It’s a 700MB download
If you have a CD-R or DVD-R/RW, could you download a live cd and try it?

I don’t know whether this helps, but the ethernet connection goes through a Virgin super hub, which I accessed via the laptop I am now using to communicate with you. The hub recognises that it is linked to a Linux computer, so the cabling appears to be working, but where is the signal?

I understand
Open Yast > Network Devices > Network Settings
See if you can configure the eth0
(I usually disable all repos and just leave the DVD available for this ir it complains that the online repos are not avail)
Yast > Software > Software Repositories

I’m in unknown territory here!
I can get through to Network Settings, where it tells me the Gigabit Ethernet controller is not connected (that’s not the case on my 11.1 by the way), but I have no idea of how to configure it, sorry.

Go to Yast > Software > Software Repositories
Disable all online repos and leave the DVD enabled. Can you manage that?

There are 10 repos listed, of which 7 are enabled. (I guess to disable these I highlight them and untick the enabled button -is that right?)
Can’t see anything that says DVD, but under the URL listing one does starte with CD. Is that the one to leave ticked? Assuming that is correct, do I then hit OK?

Actually, is it libdvdcss repository that I leave enabled? That would make more sense

10 repos in a new install?

Is this by any chance a 11.4 system upgraded from an older release?

No - nosense

Hey, I have to crash soon.
I think there is something you are not mentioning
This ethernet device should work out of the box

It was working perfectly and has done so for weeks without any problems. I haven’t touched or changed anything!!
As for holding anything back… not that I am aware of!
One odd thing. Whenever I try to connect to the email (Evolution), a screen tries to appear (I assume it’s an error message or the box I usually have to put my root password into allowing me to send or receive emails), but fades out almost immediately. Does that help?
As for the 10 repos, you may remember that you helped me with a VLC problem some time ago. I downloaded it and you helped me restore Packman settings. I suppose that is where the additional repos come from…?

From your comments, it causes me concern.
Like I said earlier. If you get a live CD (actually it doesn’t have to be openSUSE, any will do). Because I would be interested to see how your computer performs.

You see, pretty much 99.9% of PC’s using a cable connection like yours will just work.
A live CD will boot a known working system, so it will help us identify if the problem is openSUSE or your hardware.
You can burn a CD image to a DVD if you don’t have CD-R’s

OK, sounds like a good idea.
I have never come across the Live CD concept before and I’m guessing it has nothing to do with my original Suse 11.4 installer DVD. So where would I get one for my installation, which is done on a 64 bit computer? If you can provide me with a link, I will burn it onto a disk. Many thanks.

Take your pick
Index of /distribution/11.4/iso

Hi Caf4926,
I now have my live CD, which I am assuming is some sort of “mobile” OS…
So, do I now boot my PC with the disk in the drive? If so, what will I see and what should I do?
Many thanks.

It allows you to try the OS without installing. But the Ethernet should work.
Yes just boot it
Tell me if the internet works