Internet video audio problem

Okay so my sound worked fine for everything…then it just stopped. Now it only works for mplayer. I watch alot of videos online…soooo this is a problem. No sound for youtube, no sound for huluu, no sound for anything that doesn’t stream from mplayer. And considering mplayer just stops most the time and then you cant watch the rest of the video…not really a good program. Anyways i would like my audio back. Does anyone have a answer for this? If not then I will simply have to just go back to windows even though I don’t want to. Suse is too glitchy and unpredictable. Wish it was stable and things didn’t just change on you for no apparent reason.


I suppose that your problem has a solution.

Many people have different issues in linux. The worst case is the latest kernels are giving run-time issues to the older hardwares.

Simply try another linux version. Try Ubuntu. I hope your issue would be resolved.

Best of Luck.

Thats not the sort of answer I recommend on an openSUSE forum, when there are likely other solutions.

I monitor the dell ubuntu mailing list, and the amount of sound problems there with the Ubuntu distribution, that was just recommended, is horrendous. Ubuntu is no panacia for sound. Just the opposite. If you wish to go from sound problem to another sound problem, and waste time installing another distribution at the same time, then you can go ahead and waste time.

Otherwise, why not correct the problem with openSUSE, and raise a bug report where needed, and solve the problem for yourself and others at the same time?

In the applications where you have the problem, did you try changing the audio output mode in your player? Typically there are options such as “oss”, “alsa”, “aRts” … etc … Did you check to see if another device had seized the audio, and was not letting go ?

I did check that and tried all available options then reset back to the original audio format. Of course i am not advanced with linux so i could have overlooked something.

ps. Excuse my postings for seeming hostile. Im just really frustrated.

Did you check to see if another device had seized the audio, and was not letting go ?

Such as like mplayer seizing the audio so that when i go to watch youtube it won’t allow the audio to play? Im sorry, im not sure what you mean and im not sure how to check.

You could check to see if some other device has seized the audio and is not letting go. That is possible by typing in a konsole or terminal:

**lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/***

Typically, one should run that when their sound works ok, with sound playing and without sound playing in order to get a flavour as to what it looks like with their hardare and functional sound configuration. Once that baseline is established, then also run that when one has a sound problem. Then compare the outputs.

Don’t waste the forum bandwidth by posting the output here, for I won’t look at it. You need to learn how this works yourself.

Note the alsa api will allow sharing of audio devices, but the oss, aRts and other sound api’s will not.