Internet very slow on Firefox (done everything I can find on the forum)

When I had OpenSuSE 11.3 installed originally, I never had any slow internet connection until I erased the hard drive and went to 11.4. This is what my configuration looks like on /usr/sbin/iwconfig:
Cell 01 - Address: AA:AA:BA:BA:AB:BB
Frequency:2.462 GHz (Channel 11)
Quality=70/70 Signal level=-37 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Extra: Last beacon: 382ms ago
IE: Unknown: 000D686F7573657769666932303839
IE: Unknown: 010482848B96
IE: Unknown: 03010B
IE: Unknown: 2A0100
IE: Unknown: 32088C129824B048606C
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
IE: Unknown: 2D1A4E101BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D160B071B0000000F000000000000000000000000000000
IE: Unknown: DD1E00904C336E101BFFFF000000000000000000000000000000000000000000
IE: Unknown: DD1A00904C340B07030000000F000000000000000000000000000000
IE: Unknown: DD790050F204104A0001101044000102103B00010310470010E55CF3A1E66A3FF28E8AF8AA449BF1B81021000E442D4C696E6B2053797374656D73102300074449522D363238102400024132104200046E6F6E651054000800060050F204000110110011576972656C657373204E20526F75746572100800020084

The device I am using is a D-Link DWA-160 which is running the ar9170usb driver (and did on the previous version)

These are the steps I did:
Disable IPv6 from the global tab on Network Settings
Set DHCP version 4 only in dynamic address in address tab
Used the anti-IPv6 switches in firefox making these changes
network.dns.disableIPv6 change from false to true
network.http.pipelining change from false to true
network.http.pipelining.maxrequests change from 4 to 8
Added ipv6.disable=1 in DEFAULT_APPEND in Bootloader (I couldn’t find bootloader _APPENDS that was stated in another forum)
Switched from ifup to NetworkManager for Network Setup Method
Reinstalled OpenSuSE 11.4 with Ubuntu 11.04 (to see if it was OS issue) and it still didn’t work, so I switched back to OpenSuSE 11.4

Is there anything I did wrong or do I need to do anything additional? I tried giving you as much details I can and tried looking in other parts of the forums for the answer and I still can’t get the speed of web browsing or any downloading fast like it was in the past. I appreciate any help.

Here is what I get when I do /sbin/ifconfig
lo Link encap:Local Loopback
inet addr: Mask:
RX packets:133 errors:0 dropped:0 overruns:0 frame:0
TX packets:133 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11053 (10.7 Kb) TX bytes:11053 (10.7 Kb)

wlan0 Link encap:Ethernet HWaddr AA:AA:BA:AA:AA:BA
inet addr: Bcast: Mask:
RX packets:21295 errors:0 dropped:0 overruns:0 frame:0
TX packets:14957 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:19738755 (18.8 Mb) TX bytes:1832409 (1.7 Mb)

For the MAC addresses, I changed the original value to As for numbers and Bs for letters because I wanted it kept private. Its irrelevant in solving my problem anyway.

Lastly, I did just do a /usr/sbin/iwconfig wlan0 | grep which gave me this:
Bit Rate=300 Mb/s Tx-Power=27dBm

I think I did all I can until I get some sense of direction