Internet / Network connection very slow

Hi all,

I need your help because I have a big problem with my network connection. I am using a Lenovo T60 and installed the 32Bit version of opensuse 11.3. The latest updates are installed and my problem still exists.

What goes wrong: During my first call of a URL (start the firefox, write the URL and press return), the connection needs around 60 seconds to show the page. It makes no difference what I type -,,, - it needs nearly one minute to show the first page.

Now the confusing point. From this point, after I see the first side, the connection works fine. Example: I call and have to wait a minute.
If I start to search for a string the answer is as fast as the connection should be. By the way, I have a 6Mbit connection with very good response time.

As long as the webside is on the same domain, the connection works fine. But is there a call to a subdomain or a link to another side, the connection needs around a minute again.

What I did already:

stopped IPv6
stopped the firewall
switched from Networkmanager to ifup
switched from dhcp to local IP adress
modified /etc/hosts several times
changed packet size of the wlan packages - kernel parameter (found in a different forum but nothing happened)
changed mtu size to several amounts

Furhter information:
I use the wlan adapter of the laptop.
If I start a download I have aroung 500-600k download rate.

Has anyone an idea what I can do?

Best regards,

Here is a link to a very good thread on this, it was from an opensuse forum that lead to this forum here “Connect : Network is Unreachable” - HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials](

from what you are describing it sounded like this and I ran across it cause my net seemed like it was dragging also.

I am on a 2wire dsl connection myself.

original post started here, may be more info for you also. No internet from SuSE 11.3 -

they cover no internet to very slow internet. Hope it helps you.

That is exactly the symptom that you would get with a DNS set up issue. Can you post the contents of resolv.conf and try dig to check look-up times, preferably having a look if the first attempt to get a look up is a lot longer than subsequent attempts. I’m guessing that your first DNS resolver is poor/non-working/incorrect address and you wait for the first to time out before trying the second.

It could also be that your DNS points back to some other piece of networking equipment (modem/router, etc) and the configuration problem exists there.

I agree with @markone - it sound like dns/routing problems.
Try entering an ip address for a public nameserver or use your isp’s nameserver address.
It could be that if you are using dhcp, your dhcp server isn’t giving the right dns server address or its dns forwarding isn’t working correctly.

Hi all,

thank you for the replies above. Unfortunately, it seems to be not the right key.

First of all, sorry that I did not answer for such a long time. I was very very busy in the last weeks and was not able to do tests.

As some of you wrote, I changed the /etc/resolve.conf and added the DNS entries from my provider. I am not sure, but it seems to be a bit faster - but absolutely not fast enough.

Another issue is, I installed sled10 and sled11 before I switched to opensuse. I had never any speed problems with my internet connection.

Furthermore, i tried another browser, but my experiences with opera were the same.

Today, I took an ubuntu live dvd. What should I say - started the dvd, put my psk in and - fast as expected.

I am really confused now. I don´t want to switch to ubuntu or another distribution and I will not go back to SLEDx, due to the missing support and update options.

I post some config files, maybe there is a mistake that i did not see:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 2 0 0 wlan0
loopback * U 0 0 0 lo
default my.router UG 0 0 0 wlan0

more /etc/resolv.conf

Generated by dhcpcd for interface wlan0

(normally, I only have the IP of the router in the resolver file)

/etc/hosts: localhost.localdomain localhost myserver

special IPv6 addresses

#::1 localhost ipv6-localhost ipv6-loopback

#fe00::0 ipv6-localnet

#ff00::0 ipv6-mcastprefix
#ff02::1 ipv6-allnodes
#ff02::2 ipv6-allrouters
#ff02::3 ipv6-allhosts
# myserver
(last hosts entry was active and not active)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:34 errors:0 dropped:0 overruns:0 frame:0
TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2516 (2.4 Kb) TX bytes:2516 (2.4 Kb)

wlan0 Link encap:Ethernet HWaddr 00:my mac
inet addr: Bcast: Mask:
RX packets:12698 errors:0 dropped:0 overruns:0 frame:0
TX packets:11011 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12901879 (12.3 Mb) TX bytes:1697553 (1.6 Mb)

what did I further:

tried connection with eth0 (via normal lan connection via cable) - same problem
switched nscd off and on

Has anyone the final idea or another hint what I can try?

Best regards