Internet just stopped working

Hi all,

I’m a newcomer to Open Suse having just installed 13.1 Gnome. My internet connection was working fine until this morning when I switched on and noticed that airplane mode had turned on. I turned it off and connected to my wifi network, I also have an ethernet cable plugged into the laptop, but cannot access any websites either in Chrome or Firefox. I know that my router is fine because my laptop dual boots with Mint 16 and when I boot in that my internet connection is fine using the same ethernet cable.

It was all working fine when I shut down the laptop a couple of days ago. The only thing I can think of is that when I last used the laptop I followed some guidance from a forum post here to install get my Broadcom BCM 4311 wireless adapter working. However everything was working fine after I did that.

I have tried turning wifi off and just using the ethernet cable but it makes no difference and have also tried re-booting after I turned wifi off but still no joy.

Any ideas?

Thanks in advance.

There was a kernel update today, which might have broken your broadcom driver?
How did you install it?
You might need to reinstall/update it.

Oops, sorry. Didn’t notice that ethernet is not working.
Would be interesting to know what LAN adapter you have:

/sbin/lspci -nnk |grep -iA2 net

Does it help if you switch to “Traditional method with ifup” in YaST->Network Devices->Network Settings->Global Options?

What does “ip addr” say?

Can you reach hosts by IP address?


Hi wolfi323

Switching to “Traditional method with ifup” seems to have done the trick, it’s working on both ethernet and wifi now. Just a bit strange that it suddenly stopped working, as you mentioned it may have had something to do with the update earlier today.

Many thanks for your quick response.

Well, if the kernel update caused this, changing that setting should not have helped.
Did you reboot after the update?

Does it work now if you switch back to NetworkManager again?

Yes I tried restarting a couple of times without it making any difference. I have just switched it back to Network Manager and it’s working!!