Internet Connection

Suse 11.2 > updated Feb 2 using the Update UI applet.

I had internet connectivity prior to installing the updates. Now I can’t reach the internet since installing the updates. I can reach my router, log in to the router I also ping the router but I can not ping the WAN side ip on the router.

When I boot into redmond, no issues, which is what I’m using as I write this.

I have security enabled, WPA2 Personal, not that I think that is an issue as I can reach the router, my server, network printers, and PC’s.

I am running a Linksys router but have replaced the standard Linksys software with DD-WRT v24-sp2 build date 12/28/09 std. One note, DD-WRT does hand out IpV6 address but I have disabled FF from using IpV6 address along with the network connection configuration applet from accepting them. (I don’t remember the applets name)

In the redmond world this would be a certificate error, is this the same type of an issue? If so how do I fix it? (I’m new to linux/suse, but I’m already falling in love :embarrassed:)

Are you using KDE and Network Manager? There was a configuration but in Network Manager. Make sure you have the update.

KDE with network manager applet.

Have all the updates that I’m aware of, but without an active connection not sure and how would I get an update if it is available?

Not sure what you mean by “There was a configuration but in Network Manager”.

I’m having similar issues with 11.2

My set up is 10.3/11.2 on same drive different partitions with a DSL modem. I also have windoz on another drive. Both 10.3 and windoz have no problems with network access.

I just upgraded from 10.3 (still installed) which I have internet access. No internet access with 11.2, 10.3 worked from the install.

I can ping the gateway but no service beyond in 11.2 and all the settings are the same as in 10.3 and windoz. Is there anything missing or new in this distro that I am missing?

Any help would be appreciated.

greybeard01

Can you please post the output of the following commands:

ifconfig -a

find /etc/sysconfig/network -name “ifcfg-eth*” -exec echo “{}” “;” -exec cat “{}” “;”

cat /etc/udev/rules.d/70-persistent-net.rules

chkconfig -l network

  • you can remove Mac addresses from /etc/udev/rules.d/70-persistent-net.rules (the string in quotes starting with “00:”)

Results below per your request. I don’t really know what is going on, I’m new be kind, but I’m posting this from suse with a net connection(yea!). But it is only working now when I am using a wired connection.

The results I have generated are from my wireless connection only.
Do I need to re-post this in the wireless forums?

Let me know what you determine after reviewing my results.

l

inux-50rf:/home/TheB2B # ifconfig -a

eth0      Link encap:Ethernet  HWaddr 
          inet6 addr: fe80::21e:68ff:fe7b:21f1/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:2117 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1006 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1721941 (1.6 Mb)  TX bytes:114258 (111.5 Kb)
          Interrupt:28 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:110 errors:0 dropped:0 overruns:0 frame:0
          TX packets:110 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10765 (10.5 Kb)  TX bytes:10765 (10.5 Kb)

wlan0     Link encap:Ethernet  HWaddr 
          inet addr:192.168.1.37  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:3bff:fe97:3399/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:181 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:24545 (23.9 Kb)  TX bytes:6524 (6.3 Kb)

wmaster0  Link encap:UNSPEC  HWaddr 00-1F-3B-97-33-99-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

linux-50rf:/home/TheB2B # find /etc/sysconfig/network -name "ifcfg-eth*" -exec echo "{}" ";" -exec cat "{}" ";"

/etc/sysconfig/network/ifcfg-eth0
BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='RTL8101E/RTL8102E PCI Express Fast Ethernet controller'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'

linux-50rf:/home/TheB2B # cat /etc/udev/rules.d/70-persistent-net.rules

# This file was automatically generated by the /lib/udev/write_net_rules
# program,run by the persistent-net-generator.rules rules file.
#
# You can modify it,as long as you keep each rule on a single
# line,and change only the value of the NAME= key.
# PCI device 0x10ec:0x8136 (r8169)
# PCI device 0x8086:0x4229 (iwlagn)
# This file was automatically generated by the /lib/udev/write_net_rules
# program,run by the persistent-net-generator.rules rules file.
#
# You can modify it,as long as you keep each rule on a single
# line,and change only the value of the NAME= key.
# PCI device 0x10ec:0x8136 (r8169)
# PCI device 0x8086:0x4229 (iwlagn)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

linux-50rf:/home/TheB2B # chkconfig -l network

network                   0:off  1:off  2:on   3:on   4:off  5:on   6:off

your wired device (eth0) doesn’t have an IP at all. But you don’t want do use that one, do you ?
you wireless device (wlan0) has a lan IP (192.168.1.37), that it problably got dynamically from your router.

So you can ping your lan but not the Internet.
Can you ping this IP : 199.181.132.250 ? (abcnews.com)

If so, it’s a DNS issue.
In that case, for testing purpose, edit the file /etc/resolv.conf and add the line :
nameserver 208.67.222.222
Now try to ping abcnews.com

Otherwise it’s a gateway issue.
Find out your router IP and type the command:
route add default gw $IP
where $IP is your router IP ( probably 192.168.1.1 )

Does it work ?

For the purpose of testing I did not have my wired connection attached, hence no IP address.

Adding ‘route add default gw <my router ip>’ resolved the problem. Now when I am at a different location, say college, guess I will need to
a. change or remove the default gw route
b leave it
c. ???

Find out shortly as I’m off to classes for the day.

If you use ‘route add default gw’, it won’t survive a reboot.
Normally you should get the gateway automatically from you router. So, if you can ping the Internet from another location, your router at home is misconfigured. If you cannot, your wireless NIC is not configured to use the gateway it get from your router. You’re close to the solution.

You can always use ‘route add default gw’ at any time to set/change the gateway.

The problem with the missing gateway has been fixed. Update your system to the
latest version of NetworkManager and the problem should be fixed. If not, you
should delete and remake all your connections. There is a way to do it from the
“Manage Connections” option of the applet. It has been discussed several times
in the Fora.

Ran overall update on Feb 2nd, that is when my problem started. Again this evening I ran zypper update and reported back ‘nothing to do’. I’m not familiar enough with suse to know how to ran an update specifically for NetworkManager.

I’m going to go with the assumption that I have the most recent version and redo my connection list later this evening. But I’m not expecting great things, we shall see and hoping I am wrong.

removed and replaced my wireless connections and life is golden.

Darn that was simple, thanks all for your help and patience.