Internet connection (via wireless) keeps dropping out


I am running openSUSE 11.4 64-bit on a Lenovo X220t. A month or so ago while in Malaysia I began to have problems with internet communications to some sites. At the time I assumed this was related to some aspect of communications where I was staying, and it may have been. But maybe not. In the past few days I have had repeatedly an experience which I now realize is a consistent pattern. I start the machine. Good connectivity. Some time later, the machine goes to sleep. I bring it out of sleep, and I no longer have a connection to the web. I can’t think what I have changed in the past few days or weeks. Its very frustrating because our university Email is on Google and you write a letter , then find you can’t send it or save it as draft, so you copy and paste and save elsewhere and reboot. Impossible to live with. Last night I went through updates (on a wired connection), hoping this might cure the situation. If anything it’s even worse. The machine doesn’t even need to go to sleep to cause this loss of connectivity. I keep having to turn off and back on the hardware switch for wireless. Any suggestions? Thanks, John

I powered down our provider’s wireless broadcaster and re-started it… fingers crossed, this seems to have solved the problem. It had not occurred to me to suspect that equipment, because the openSUSE notification icon had always been showing a good connection throughout all these headaches. John.

Thanks for posting on this and sharing your solution. Out of curiousity, which wireless do you have in your Lenovo X220t ?

My wife has an X220 (not an X220t) with the Intel Corporation Centrino Advanced-N 6205 [8086:0085] wireless. My research before recommending to my wife to get an X220 with the N 6205 was that it appeared to receive reasonable GNU/Linux reviews, while the ThinkPad b/g/n wireless driver was still under development at the time of my wife’s purchase (planned for the 2.6.39 kernel) and the Intel Centrino Wireless-N 1000 wireless required work arounds to get functioning. But the N 6205 purportedly just worked.

Thus far the wireless has just worked for my wife, but I have to note she is not much of a GNU/Linux user, and her useage time is short and typically she spends more time with Windows7. Typically she goes to GNU/Linux only when she has multimedia interests, as I have her openSUSE-12.1 multimedia setup superior to what she has her Windows7 multimedia setup.

Thanks for the comment. Its embarrassing to confess having overlooked simple possibilities, but that’s me sometimes. My machine also has Intel Centrino Advanced-N 6205 AGN. I must say I didn’t put much thought into it. It has worked just fine, and to the best of my knowledge any problems I have had lie elsewhere. I wanted the tablet version (I had an X61 tablet which openSUSE ran fine) but I have not had the tablet functionality, perhaps because I’m running 11.4