internet connection shows connected but can't access the internet!!!!

so today i was using my laptop as always plugged my USB modem , clicked it , connection status => connected , so everything’s fine

but then firefox says it can’t connect to the server , i tried the usb modem on linux mint (with my very same laptop) and the USB modem’s fine
then i tried ping command from konsole

ping http://www.yahoo.com => host not found

ping 8.8.8.8 => icmp open socket: Operation not permitted

i googled icmp open socket: Operation not permitted
came up with a chmod u+s ‘which ping’ (or a command that looked like that i cant remember)

that fixed the ping 8.8.8.8 problem , however i still can’t connect to the internet using firefox and ping http://www.yahoo.com still gives the same result !!!

im on openSUSE 13.1 KDE

Maybe your /etc/resolv.conf is corrupted.

Try to run “sudo netconfig update -f”.

thank u aloooooooooooooot rotfl!

that solved it

B.T.W , the code was : sudo /sbin/netconfig update -f

Yeah right, sorry.

The /sbin/ is not in the path when you use sudo as user to get root permissions.