internet connection problem using kppp


I have a Mobidata EDGE modem, I have configured it using KPPP. It used to work fine. But after few days, it stopped working.

When I try to connect internet via kppp, it finds my modem, sending initializing command, then it starts waiting for response from my modem. Some time this problem does not occur.

Things may be noted:

I tried kinternet, didn’t succeeded. I tried wvdial, same problem, some time it connects me to internet, some time sending ATZ command failed! It seems the KPPP is suffering the same problem.

I always use this two commands to register my modem to ttyUSB0.

$ modprobe -r usbserial
$ modprobe usbserial vendor=0x10ce prod=0xea6a

I am using openSUSE 11.0 and KDE4

Please help me, as no inetrnet, no life on my openSUSE :frowning:

It seems that I have solved the problem :slight_smile:

I just disable the modem volume.

I don’t know exactly the reason why have it worked now, may be sending volume commands is not supported.

Shed some light on this please.

It seems the problem was solved temporarily. I am facing the problem once again :frowning:

Please help me.