Internet appears to be connected but will not work

After enjoying openSUSE 13.2 (32-bit) on my laptop with no issues I decided to install the 64-bit version of openSUSE 13.2 on my main PC along with Windows 10 (it has a 64-bit CPU where my laptop does not. I also previously dual-booted Windows 10 and Debian and before that Windows 10 and Lubuntu). So far it has been working fine except 1. NetworkManager does not start on boot (running service NetworkManager start in terminal will start it up though) and 2. Once I get it started and attempt to connect, the KDE 4 menu for NetworkManager on the taskbar tells me its connected and working fine, however loading a website in Firefox will not work, openSUSE will not find updates (saying Could not resolve host: and pinging a website in terminal (i.e. will say ping: unknown host To make sure this is not an issue with my network I tested all of this on my laptop and it worked fine (I also wrote and posted this on my laptop). Anybody have any ideas? Thanks!

It seems that you can not resolve hostnames.

But you may still be able yto connect to systems on the internet. You check that by ping to an IP address, not to a host name. Thus e.g.

ping -c1

Have you switched to NetworkManager in YaST->Network Devices->Network Settings->Global Options?

If not, how are you starting NetworkManager? “systemctl start NetworkManager” I suppose…
You probably have both NetworkManager and Wicked running and managing the same interfaces, which is bound to cause problems.
You would need to stop Wicked first, before starting NetworkManager.

So, open YaST->Network Devices->Network Settings->Global Options, switch from “Wicked Service” to “NetworkManager Service”, and it will hopefully work.

Interestingly enough, or at least interesting for me, it worked.

Solved the issue! Thank you!