Internal mic not working on ACER 5635


I have a new notebook (ACER Extensa 5635) and I can’t make internal or external microphone working. Volume for mic is set to maximum. I have :
cat /proc/asound/card*/codec#*|grep -i codec
Codec: Conexant CX20561 (Hermosa)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

I have opensuse 11.2 (all updates installed).



What desktop are you using? (KDE ? Gnome ? )

Please configure your mixer exactly the way you think it should be configured for your mic to work.

Note when testing your mic, I recommend you use a terminal with this command:

  arecord -vv -fdat foo.wav

“foo.wav” is an arbitrary name I made up. Instead you could call it mydell.wav or thewindblows.wav or anything …

Then assuming mic does not work, please provide the information recommended to be provided here: Welcome to multimedia sub-area - openSUSE Forums and I will quote this for you:

please post … the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/ and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Note that if for some reason the “/usr/sbin/” script does not give you a website URL then run it with the no upload option this way:

/usr/sbin/ --no-upload

and that will create the file /tmp/alsa-info.txt. Open that file with a text editor and paste it here: New - Pastie and press paste and post here the URL it provides.

That will provide more information that can help in figuring out your problem.


hmm arecord command successfully record sound from internal mic. Sorry for spamming :slight_smile: and thanks for support.

Great news !

A hint that works for me: I find the mixer settings for the internal/external mics in Linux can be a bear at times to get working properly. What I have done is get each external and internal mic working, and then take a screen dump of the mixer settings, and I post the jpg on a folder on my desktop. And hence next time I struggle with my mic (and I always do - primarily due to my pathetic memory) I simply open up the jpg in the folder on my desktop, and read the functional mixer settings.