Internal mic no sound after openSUSE 13.2.

After upgrade from 13.1 to 13.2 the internal microphone on my Compaq laptop doesn’t work.
It’s a dual boot laptop and in the Windows partition the mic works ok.
pulseaudio is at 5.0-4.15.1. and pavucontrol is at 2.0-4.2.1. Output from
/usr/sbin/ is available at](
Any help welcome.

All the volumes up and not muted??

Does it show up in pavolcontrol??

Do you see it in Yast sound??

Yep. All looks ok in Yast sound and pavucontrol. I first got the problem in skype but I’ve tried audiorecord and it happens there too. Everything was fine without any user configuration on 13.1.

I’m not familiar with audiorecord …

I took a look at the mixer configuration in the script link provided and I note:

**Simple mixer control 'Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 0 **[0%] **[0.00dB]
  Front Right: 0 **[0%]** [0.00dB]
**Simple mixer control 'Capture',0**
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 80
  Front Left: Capture 80 [100%] [6.00dB]
  Front Right: Capture 80 [100%] [6.00dB]
**Simple mixer control 'Auto-Mute Mode',0**
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
**Simple mixer control 'Digital',0**
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 **[50%] **[0.00dB]
  Front Right: Capture 60 **[50%]** [0.00dB]
**Simple mixer control 'Internal Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 4 [100%] [40.00dB]
  Front Right: 4 [100%] [40.00dB]

In one case boost is at 0% and I also note capture only at 50%. You could try increasing both of those.

wrt testing, I note this:

**** List of CAPTURE Hardware Devices ****
**card 0:** Intel [HDA Intel], **device 0**: CX20561 Analog [CX20561 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

which tells me the record device is hw:0,0.

Type this in a terminal and see if you can record your voice while this is running. Press < ctrl-c > to stop it.

arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav

play back the file “new.wav” and see if it recorded. Also, if that failed to execute, post here the errors. You could also try as a regular user, and also in the konsole/xterm in which that runs, switch to root if it fails as a regular issue, so to investigate the possibility of a permissions issue.

My understanding is the app “arecord” bypasses pulse audio, so what I am trying to figure out here if your difficulty may be no more than a pulse audio configuration issue.

Tried upping the mic boost to 100% but there’s no difference. Also tried record under Root id but still no luck. Tried the suggested arecord command but again, no sound. Here’s the output:

arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav
Recording WAVE ‘new.wav’ : Signed 16 bit Little Endian, Rate 8000 Hz, Stereo
Warning: rate is not accurate (requested = 8000Hz, got = 44100Hz)
please, try the plug plugin
Hardware PCM card 0 ‘HDA Intel’ device 0 subdevice 0
Its setup is:
stream : CAPTURE
format : S16_LE
subformat : STD
channels : 2
rate : 44100
exact rate : 44100 (44100/1)
msbits : 16
buffer_size : 22052
period_size : 5513
period_time : 125011
tstamp_mode : NONE
tstamp_type : GETTIMEOFDAY
period_step : 1
avail_min : 5513
period_event : 0
start_threshold : 1
stop_threshold : 22052
silence_threshold: 0
silence_size : 0
boundary : 1445199872
appl_ptr : 0
hw_ptr : 0
#+ | 00%^C
Aborted by signal Interrupt…
#+ | 00%

Wondering if this may be to do with having a mono mic and pulseaudio geared for stereo.

No mono mics are ok

open pavolcontrol (install if you have not yet)

go to output device you should see a level bar that shows the level of the sounds to the mic

If in yast you show more then on e sound device try changing the order

From what I can see, recording was taking place and the file new.wav was created, but the record levels were too low to capture anything. To the best of my knowledge, arecord bypasses pulse audio, and hence this does not appear to be a pulse audio problem (albeit I could be wrong).

I also understand from your first post that this worked in openSUSE-13.1 and stopped working when you did not do a clean install, but rather when you did an upgrade from opensuse-13.2. If the mic never worked in openSUSE-13.1 please tell me, as my assumption for future recommendations is based on the assumption that it did work in 13.1.

Before trying anything, can you again run the diagnostic script and provide here the output URL. I want to verify that the control adjustments you stated you applied, actually were applied. Apologies for asking, but in my experience on this forum, many users claim they tried to make the adjustments, but in practise they failed. Hence the need for this quality check.

You could try toggling back and forth the mixer contro"Auto-Mute Mode" setting, albeit that is very much a long shot.

Then, after your running the script, and providing me the URL where the script information upload is located, try removing the /etc/modprobe.d/50-sound.conf file (make a backup first to your /home/username) and then restart your PC, configure your sound with YaST and try your Mic again.

I also note your PC has a CX20561 (Hermosa) hardware audio codec (from the dmesg at the bottom of the script output) . I believe a CX20561 is the same as a Conexant 5051 where there are audio models that can be forced upon boot (one at a time) as documented in the /usr/src/linux-versioin/Documentation/sound/alsa/HD-Audio-Models.txt file that is on your PC (and also on my PC). We could consider trying those, albeit I am reluctant to do so, as you made no mention of that ever being required with openSUSE-13.1 and my understanding is the Mic worked for you in openSUSE-13.1. Also I took a look at linlap for the CQ60 laptop, and no one has indicated problems with the Mic nor requiring any special configuration in a boot file. This should ‘just work’.

There could be a bug on this … I note reply#63 in this thread on the CQ60

Assuming this is the case, then the quickest way to get this mic working is to raise a bug report on openSUSE-13.2 kernel, for not working with the CQ60 internal Mic. openSUSE audio is packaged by a SuSE-GmbH alsa driver developer, so if anyone can solve this problem, he can. Also, any fix he puts in the driver will help all other GNU/Linux distributions.

Provide all salient information in the bug report. Do not bother referencing this thread, as the SUSE-GmbH alsa developer will not read an openSUSE forum thread. Copy to the bug report the output (in a text file) of the script being run (/usr/sbin/ --no-upload) . You could also include reference in the bug report to the 2014 kernel bug report and also the ubuntu bug report

There is guidance here on how to raise a bug report:

You can use your openSUSE forum username and password when logging on to bugzilla.

Again, if anyone can solve this, the SUSE-GmbH alsa developer can.

Good luck.

Thanks for all your efforts. I’ll raise this as a bug and post the outcome here.

Bug number is 920604.

Thanks. That is a fascinating thread/bug report: and the exploratory suggestions you are being given to try by Takashi (who in addition to being a SUSE-GmbH sound packager, is also an alsa sound driver developer/maintainer team member) are massively beyound my knowledge of this audio subject.

While in that bug report there has been no luck so far, I have my fingers crossed for you.

I’ve been watching the bug report with interest, and it reads that you and Takashi have come up with a working solution - and Takashi will be submitting the fix upstream which will aid every other GNU/Linux distribution.

Well done for working with Takashi on this and thankyou very much for your contribution here!

Yes, there is a temporary fix which involves adding a couple of small parameter files and the offical kernel patch will be available soon. Many thanks for your input.